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VOLUME – I                               STAR OFFICE 

 1.AN INTRODUCTION TO STAROFFICE WRITER 

I. Two mark questions:  

1.What is meant by text editing? [Mar-09, Oct-09, Mar-10, Oct-10, Mar-13, Mar-16, 

June-16, Oct-16] 

Text editing: 

� Entering a new text or modifying the existing text in a document is known as text 

editing. 

� Text editing also involves cut, copy, changing the font color, type, find and 

replacing the text in the document. 

 

2.What is word processing? [Oct-12, Oct-14, Mar-15, June-15, Mar-17] 

Word processing: 

� Star Office Writer is a word processor.  

� The term word processing refers to the activity carried out using a computer and 

suitable software to create, view, edit, manipulate, transmit, store, retrieve and 

print documents.  

 

3.How will you select the text with keyboard? [June-07, June-14] 

Selecting Text with Keyboard: 

1. Insertion point is moved to the start of the text to be selected. 

2. The Shift key is pressed down and the movement keys are used to highlight 

the required text. 

3. When the Shift key is released, the text is selected.  

 

4.What are the difference between copying and moving text in star office writer? [Oct-07, 

Mar - 14] 

Difference between copying and moving text: 

Copying text Moving text 

When copying, the text appears on 

both source place and target place. 

When moving, the text appears on 

target place only. 

Edit → Copy and Edit → Paste 

                    (or) 

    Ctrl + C  and  Ctrl + V 

Edit → Cut and Edit → Paste 

                    (or) 

    Ctrl + X  and  Ctrl + V 
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5.How will you correct mistakes in star office writer? (or) What is the difference between 

backspace key and delete key? [June-08] 

Backspace key and delete key: 

� All the characters, which are typed, appear on the screen. If a mistake is 

identified it can be corrected either using the Backspace key or the Delete key.  

Backspace key Delete key 

Backspace key deletes the 

characters to the left of the 

insertion point.  

Delete key deletes the characters to 

the right of the insertion point. 

 

6.How do you switch over from insert mode to type over mode? [June-10] 

Switch over from insert mode to type over mode: 

� The user is in the type-over mode, if the text existing to the right of insertion 

point disappears, while typing a new text.  

� The user is in the insert mode, the new text will be inserted and the existing text 

would move to the right. 

� The user can toggle between type-over mode and the insert mode by using the 

Insert key.  

� The status bar gives the information about the current mode. 

 

7.How to work with multiple documents in star office writer? [Mar-11] 

Working with Multiple Documents: 

� While working with Star Office Writer, it is possible to have several documents 

open at the same time. Once the documents are open, you can switch between 

them in the following two ways. 

1. Click on the Window menu option and select the file from the list of 

documents displayed. 

2. Click on the document button visible on the taskbar. These documents can be 

closed one by one by using the File → Close command. 

 
8.Write any four word processing package? [June-13] 

Word processing package: 

� StarOffice Writer is a word processor.  

� Some of the other commercially available word processing packages are               

M.S.Word, Lotus AmiPro, Word Perfect, Word Star and  Word Pro. 

 
9.How will you close a document in star office writer? 

Closing a document: 

� After a document is saved, it is not closed. It remains open so that the user can 

continue working.  

� When the work is finished, the user should save and close the document.  

� After saving, the document can be closed using the File→ Close command. 
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10.How will you save a document in star office writer? 

Saving a Document: 

To save a document for a first time following steps are used: 

1. File → Save command is selected or        icon is clicked. A Save As dialog box 

appears on the screen. 

2. A double click is made on the required folder and the file name is given in the File 

name list box. And click on the Save button to save the document. 

3. The document is now saved and a file name appears in the title bar. 

4. Ctrl + S is the keyboard shortcut for saving the document. 

 

11.How will you select the required portion of the text in star office writer? 

Selecting Text: 

� For selecting text the mouse or the keyboard can be used. 

Selecting Text with Mouse:  

� The left mouse button should be clicked, held down and dragged across the text 

to be selected. 

� When the text is selected, the mouse button should be released. 

Selecting Text with Keyboard: 

� 1. The Shift key is pressed down and the movement keys are used to highlight 

the required text. 

� 2. When the Shift key is released, the text is selected.  

 

12.What is meant by scrolling the document? 

Scrolling The Document: 

� If the document is long the text can be scrolled through without moving the 

insertion point.  

� This can be easily done using the mouse. 

� There are two sets of scroll arrows; one for up and down movement and the other 

for the left and right movement of the document. 
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2.TEXT FORMATING 

1.What are the steps in creating “Bulleted List” in a star office writer document? [Mar-07] 

Following steps are used to create a Bulleted list: 

� Select the text that to which bullets are to be added.  

There are two ways to add the bullets for the paragraph, 

1. Click on the Bullets icon         from the formatting tool bar, Star Office Writer 

creates a  bulleted list, 

2. Choose Format → Bullets and Numbering, command can also be add bullets to 

the paragraph. 

 

2.How will you create numbered list in star office writer? [Mar-08, Jun-09] 

Following steps are used to create a Numbered list: 

� Select the text that to which numbers are to be added.  

There are two ways to add the numbers for the paragraph, 

1. Click on the Numbering icon         from the formatting tool bar, StarOffice Writer 

creates a  Numbered list, 

2. Choose Format → Bullets and Numbering, command can also be add Numbers 

to the  paragraph. 

 

3.What are the different types of paragraph alignment in star office writer? [Oct-08,      

June-12, June – 15] 

Types of paragraph alignment: 

There are four types of paragraph alignment in star office writer. That is, 

1. Left alignment  - To make the text as Left-aligned press Ctrl + L            

2. Right alignment - To make the text as Right-aligned press Ctrl + R     

3. Centered  - To make the text as Centered press Ctrl + E 

4. Justified  - To make the text as Justified press Ctrl + J    

 

4.How to change the line spacing in star office writer? [Jun-11, Oct-13] 

To change the line spacing, following steps are used: 

1. Select the paragraphs(s) that needs to be changed. 

2. Select Format → Paragraph. 

3. If necessary, click the Indents & Spacing tab.  

4. Click on the Line spacing drop-down list box, and select the required line 

spacing option. 

5. Click the OK button. 
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5.How to create Bullets and numbered list? [Oct-11] 

To create a Bulleted list & Numbered list: 

� Click on the Bullets icon         from the formatting tool bar, StarOffice Writer 

creates a bulleted list, 

� Click on the Numbering icon         from the formatting tool bar, StarOffice Writer 

creates a  Numbered list, 

� Choose Format → Bullets and Numbering, command can also be add Bullets 

and Numbers to the paragraph. 

 

6.What are the line spacing options available in star office writer? [Mar – 14] 

Line spacing options: 

� By default, StarOffice Writer single-spaces the text in the document.  

� Single line, 1.5 lines, Double, Proportional, At least, Leading and Fixed are the 

line spacing options available in star office writer. 

 

7.What is meant by hanging indent? [Oct-11, Mar12, Mar-17] 

Hanging indent: 

� In a paragraph, when first line hang outside the paragraph is known as hanging 

indent. 

� Hanging indent is a special kind of indent, used for numbered lists. 

� The First line option can be used to indent the line of the paragraph.  

� Using the spin arrows, if a positive value is specified, the first line will be 

indented.  

� A negative value will result in a hanging indent; that is, the first line will hang 

outside the paragraph. 

 

8.What is meant by indent the text? [Oct – 15] 

Indent the text: 

� Indentation helps in providing the document with more readability. 

� Alignment changes are most appropriate for headings or other special paragraphs 

in the document.  

� For instance, indent the first line of each paragraph. This visual clue helps the 

reader to see how the document is divided into paragraphs.  

� The paragraphs also indented, such as quotations that are set apart from the main 

document text. 
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9.What is the different between hard and soft formatting? 

� There are two types of formatting (i.e.) hard formatting and soft formatting. 

Hard Formatting Soft Formatting 

A Hard return is inserted 

every time when enter key 

is pressed 

Soft returns are inserted as line breaks 

by star office writer and are adjusted 

when text is added or deleted. 

For example,  
Ctrl + J , Ctrl+ O 

For example,  
icons and formating 

 

10.What is the use of highlighting the text? 

Use of highlighting the text: 

� Highlighting can be used to call attention to key ideas or pointers in a document.  

� When reading something important in a book, a magazine, a report, or any 

document, the reader takes a yellow highlighter pen and drags across it.  

� These highlighted sections are used to review or find the key points in the 

document. 

� The colour to be used for highlighting can also be selected. 

 

11.What are the types of help systems in star office writer? 

StarOffice Help: 

StarOffice 8 provides several help systems that you can use while you work: 

i) Online help 

ii) Help Agent 

iii) Help Tips 

iv) Extended Help Tips 
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3.CORRECTING SPELLING MISTAKES 
1.How does star office writer check spelling while typing? [Oct-07] (or) What is meant by 

auto spell check icon? [Oct-16] 

Checking Spelling While Typing 

� StarOffice Writer has an automatic spell-check feature that can check for possible 

spelling mistakes even as the document is being typed.  

� Auto Spell Check feature can be turned ON or OFF by clicking on the icon         . 

This icon is called Auto Spell check icon. 

� When Auto Spellcheck feature is ON, StarOffice Writer compares each word 

typed with the words in the dictionary and underline words that do not match 

with a squiggly red line.  

� The correction can be made after the document is created. 

2.What is the use of auto correct option? [June-08] 

Use of auto correct option: 

� Auto Correct option is very useful for correcting the spelling of the commonly 

misspelled words.  

� If the error and its correction are to be added to the Auto Correct list the 

following command is used: Tools → AutoCorrect 

� For instance, if a word is typed as “teh”, StarOffice Writer automatically replaces 

this with the correct word “the”. 

3.What does automatic spelling correction mean? 

Automatic spelling correction: 

� Automatic spelling correction means, If the right spelling is not known, 

StarOffice Writer can help the user with some choices.  

� The misspelled word is right clicked. A popup menu appears on the screen.  

� If the correct spelling is shown, a click is made on that word. StarOffice Writer 

makes the replacement. 

4.How will you open spell check dialog box? 

The following steps are used for a spell check. 

� Tools → Spelling → Check command is selected (or)         icon is clicked to 

open a spell check dialog box in star office writer.  

� The F7 key may also be pressed to select the spelling command. 

5.How will you add a word in the auto correct list of the star office writer? 

Add a word in the auto correct list: 

� If the error and its correction are to be added to the Auto Correct list the 

following command is used Tools → AutoCorrect, now auto correct dialog box 

appears on the screen. 

� In this box, with the Replace tab selected the word to be replaced is typed in the 

Replace text box and the replacement word in the With text box.  

� When the same mistake is made StarOffice Writer will automatically replace the 

misspelled word with the correct spelling. 
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 4.WORKING WITH TABLES  

1.How will you make the selected row/column the same size in star office writer? [Jun-07, 

Oct-10, Mar-12, Oct-14] 

To Make Selected Rows/Columns the Same Size 

� Select the rows and columns that are to be resized. 

� To make all columns even, right click inside the table and select                      

Column → Space Equally in the pop-up menu. 

� To make all rows even, right click inside the table and select                              

Row → Space Equally in the pop-up menu. 

 

2.How will you delete the entire table in star office writer? [Oct-09, Oct-12, June-13, 

Mar-15, Oct-15] 

To delete the table the following steps are used: 

� Table → Select → Table command can be used to select the entire table. 

� The menu option Table→ Delete → Table is used to delete the selected table. 

 

3.How will you insert rows & columns in a table in star office writer? [Mar-09] 

Adding Rows: 

� The simplest way to add a row is to press Tab in the last row of the table.  

� Choose Table → Insert → Rows command can be used to insert more than one 

row in a table. 

 

Adding Columns: 

� Choose Table → Insert → Columns command can be used to insert more than 

one column in a table. 

 

4.How to change the width of the column in a table? [Jun-09] 

Changing the Column Width 

To change the row/column width, follow these steps: 

� To resize a column, place the cursor in a table cell, hold down Alt, and then press 

the left or the right arrow.  

� To resize the column without changing the width of the table, hold down Alt + 

Ctrl, and then press the left or the right arrows. 

� Alternatively if Table → Table Properties command is used to change the 

column width. 
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5.How will you create simple table in star office writer? [Mar-16] 

Creating a Simple Table 

� When Table → Insert → Table is selected from the menu bar, the Insert Table 

dialog box appears on the screen. 

� In the Name textbox the name of the table is given.  

� Using the spin arrows in the Columns and Rows text box the number of columns 

and rows are entered.  

� StarOffice Writer displays the table as a grid with the specified number of 

columns and rows. 

 

6.How will you delete the rows & columns in star office writer table? [June-14] 

Deleting Rows: 

� Choose Table → Delete → Rows command can be used to deleting the rows. 

� Also click the           icon deletes the current row from the table. 

Deleting Columns: 

� Choose Table → Delete → Columns command can be used to deleting the 

columns. 

�  Also click the          icon deletes the current Column from the table. 

 

7.How to change the row height & column width in star office writer table? 

Changing the Rows/Column Width 

To change the row/column width, follow these steps: 

� To resize a column, place the cursor in a table cell, hold down Alt, and then press 

the left or the right arrow. To resize the column without changing the width of the 

table, hold down Alt + Ctrl, and then press the left or the right arrows. 

� To resize a row, place the cursor in the row, hold down Alt, and then press the up 

or the down arrows. 
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5.PAGE FORMATTING 

1.How will you create header in star office writer? [Mar-07, Mar-10] 

Create header: 

� Header is an area at the top of page. 

� To create a header, the Header tab on the Page Style dialog box can be used.  

� In this dialog box, the Header on check box is clicked.  

� Four spin boxes are also displayed. In those spin boxes the distance of the header 

from the text area, the header height, the distance from the left margin and the 

right margin are entered. 

 

2.What is the purpose of creating footer? [Mar-08] 

Purpose of creating footer: 

� When the documents are longer than one page, normally some type of reference 

numbers are added on the page.  

� For instance, page numbers are a must. Otherwise even if the pages are stapled or 

bound, a particular page cannot be easily referred.  

� For this purpose we want to create footer in star office writer document. 

 

3.What are the types of page orientations? [June-10, June-12] 

Types of page orientations 

� There are two types of page orientations are there in star office writer. That is, 

1. Portrait 

2. Landscape 

� Usually the length of a document will be more than the width. This orientation is 

called portrait.  

� But in some of the documents the width will be more than the length. This type 

of orientation is called landscape.  

� The default orientation is portrait. 

 

 

4.What is meant by header and footer? [Oct-08, Mar-11] (or) What is the use of header 

and footer in star office writer? [June-16] 

Header and Footer: 

� Header is an area at the top of page. 

� Footer is an area at the bottom of page. 

� Header and footer are some references remarks added at every page of the 

document of the top and bottom margins respectively. 
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5.What is meant by footer? How will you insert a page numbers in footer area? [June-11, 

Oct-13] (or) What is meant by header? How will you insert a page numbers in footer 

area? [Mar-13] 

To insert page numbers in footer: 

� Header is an area at the top of page. 

� Footer is an area at the bottom of page. 

� Click on the footer area, choose Insert → Fields → Page Number command can 

be used to insert page numbers on every page.  

 

6.How will you create footer in star office writer? 

Create Footer: 

� Footer is an area at the bottom of the page. 

� To create a footer, the Footer tab on the Page Style dialog box can be used.  

� In this dialog box, the Footer on check box is clicked.  

� Four spin boxes are also displayed. In those spin boxes the distance of the footer 

from the text area, the footer height, the distance from the left margin and the 

right margin are entered. 

 

7.What is meant by page formatting? 

Page formatting: 

� Page formatting means that, Margins control how close StarOffice Writer prints 

to the edge of the page. 

� Changing the page border, page orientation, page size (or) paper size, also add 

the Header and Footer in the document is called page formatting. 

 

8.How can the ruler be used to change the margin? 

Changing Margins Using Rulers: 

� If the user is not having the exact value for the margins then the Ruler option on 

the View menu can be used to change the margins. 

� If the ruler is not displayed in the screen, View → Ruler option is clicked. 

� The gray area of the ruler indicates the margin’s top area. 

� The mouse pointer is then moved in between the gray and white area of the ruler. 

� When the pointer is in the right spot, it changes into a line with arrows on both sides. 

� The margin guide is dragged to a new location. 
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6.SPREADSHEET 

1.What is the different between absolute and relative cell addressing? (or) Name the 

different types of cell referencing? (or) Write a note on different types of cell 

referencing? [Mar-07,  Jun-09, June-14, Mar-15, June-15, Oct-16] 

Relative cell addressing: 

� Relative cell addressing is the default type of cell addressing used by StarOffice Calc. 

� you typed the formula = C3+D3+E3+F3 in cell G3 and then copied it to the cells 

G4:G7. Click on the cell G4. Note that the formula in this cell is =C4+D4+E4+F4. 

� This type of cell referencing is called Relative cell addressing. 

Absolute cell addressing: 

� A cell address can be made absolute by using the $ (dollar) sign in front of row 

and column names. 

� Absolute cell addresses do not change when copied. 

For example, the C4 becomes absolute when you enter it as $C$4. 

 

2.What do you mean by date arithmetic in star office calc? [Mar-07,Jun-08, Oct-08, Mar-

10, Jun-12, Mar-12, Mar-13, June-14, Mar-16, Mar-16]  

Date arithmetic: 

� In spreadsheets, date calculations become very simple. Here you can add a 

number to a date and arrive at a new date, find the difference between two dates 

and use a wide variety of function and formats to get what you want. 

� For example, suppose you want to calculate the difference between two dates, 

05/10/05 and 12/8/70. To do so, enter the two dates in two different cells. In a 

third cell enter the formula = first cell – second cell. The result will be displayed 

as 12572. 

 

3.What is the use of auto format sheet? (or) Write a note on auto format sheet in star office 

clac? [Jun-07, Mar-08, Jun-10] 

Use of auto format sheet: 

� The AutoFormat Sheet facility of StarOffice Calc helps to format the worksheet 

with different predefined styles and colours. 

� To get Auto Format dialog box, Click on the AutoFormat option in the Format menu.  

 

4.How will you save a worksheet? [Mar-08, Mar-16] 

Save a worksheet: 

� To save the worksheet created, go to the File menu and select the Save or the 

Save As option. 

� Type in a file name and click on Save.  

� You can also click on the Save icon on the Standard toolbar (or) The keyboard 

shortcut Ctrl + S also used to save a worksheet. 
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5.Can we change the data present in a cell? If so, how? (or) How can we edit the data 

present in a cell in star office calc? [Oct-07, Mar-09, June-10, Oct-10, June-11,    

Mar-12, Oct-16] 

Edit the data present in a cell: 

� To edit the data present in a worksheet, first open the worksheet by clicking on 
File → open. 

� The data present in a worksheet, you can edit the contents in the following two ways: 

1. Type in the new data. The new data will simply overwrite the old contents of  

the cell. 

         2. Click on the formula bar with the mouse, press the F2 function key or simply 

double- click on the cell. A vertical cursor appears on the formula bar. Move the cursor 

to the left using the left arrow key or the backspace key and edit the data. 

 

6.Write the spread sheet applications? [June-08, June-13] 

Spreadsheet applications: 

� There are numerous applications possible using electronic spreadsheets.  

A few of the common applications are given below: 
• Payment of bills 
• Income tax calculations 
• Invoices or bills 
• Account Statements 
• Inventory Control 
• Cost-Benefits Analysis 
• Financial Accounting 
• Tender Evaluation 
• Result analysis of students 

 

7.What are cell and cell pointer? [Oct-08, June-16] 

Cell: 

� The intersection of rows and columns creates cells.  

� The cells are addressed in terms of the row and column labels.  

� Any data, like numbers, text or formulae can be typed into a cell. 

Cell Pointer: 

� The active cell in which you want to type the data is identified by the cell pointer 

which is a rectangular box covering that cell.  

� To begin with, the cell pointer is always in cell A1.  

 

8.Define electronic spread sheet? [Mar-09, Oct-12, June-13, Oct-15, June-16] 

Electronic Spreadsheet: 

� An electronic spreadsheet is a worksheet used in a computer to create and quickly 

perform “What if” analysis of interrelated columnar data in workspaces. 

� Spreadsheets are made up of rows and columns. The intersection of rows and 

columns creates cells.  
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9.What is meant by range? Give example. [June-09, Mar-14, Oct-14] 

Range: 

� A continuous group of cells in a worksheet is called a Range. A range is referred 

to by the range address.  

� A range address is the address of the first cell in the range, followed by a colon, 

followed by the address of the last cell in the range.  

� For example, the cells, G1, G2, G3, G4 and G5 can be called G1:G5. 

 

10.Write the names of popular spread sheet package? [Oct-07, Oct-13] 

Popular Spreadsheet software: 

Spreadsheet Software Company 

Lotus 1-2-3 Lotus Corporation 

Improve Lotus Corporation 

Star Office Clac Sun Micro System 

Quattro Pro Borland International 

MS-Excel Microsoft Corporation 

 

11.Write a note on text operators in star office calc? [Oct-09, June-15] 

Text operators in star office calc: 

� The operator combines sections of text to the entire text. 

Operator Name Example 

&(And) Text operator: And “Star” & “Office” yields   

        “StarOffice” 

    

12.What are functions in star office Clac? How can you insert them in the work sheet? 

[Oct-10, Oct-11, Oct-12, Oct-13] 

Functions in star office Clac: 

� StarOffice Calc has a wide variety of functions that allow you to perform several 

frequently done calculations.  

� Functions are predefined formulae that are available in StarOffice Calc.  

� To select a function, go to Insert menu and Select the Function option. 

�   The Function Wizard shortcut icon on the formula bar can also be used to 

select and insert functions. 

 

13. List any four advantages of electronic spread sheet? [Mar-11] 

Advantages of electronic spread sheet: 

� Accurate results to any desired level of decimal points are possible. 

� Worksheets can be quite big in size. 

� Any part of the worksheet can be viewed or edited. 

� Worksheet can be saved and retrieved later. 
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14.Explain how to generate the series: 33, 30, 27,……………….., 3? [Mar-10] 

� Choose the command Edit → Fill → Series. In the Fill series dialog box,  

select Direction as Down,  

Type as Linear,  

33 as your Start value,  

3 as end value  

and Increment as -3.  

� Then by clicking the OK button the values in the subsequent cells of the column 

will be automatically generated. 

 

15.How will you change the column width of a cell in work sheet? [June-12] 

Change the column width of a cell: 

� To change the column width, select the column whose width you want to change.  

� Click on Format → Column → Width and type the new column width in the 

dialog box, which appears on the screen.  

� Click on OK. 

 

16.What is meant by auto fill command? [Mar-13]   (or)  How can you generate a series of 

values? Explain with an example. 

Auto fill command: 

� AutoFill automatically generates a data series based on a defined pattern. 

1. On a sheet, click in cell, and type a number. 

2. Drag the fill handle in the bottom right corner of the cell across the cells that 

you want to fill, and release the mouse button. 

 

17.What is the reference operator in star office calc? Give example. [Mar-17] 

Reference Operators:  

� The reference operators are used to combine areas. 

Operator Name Example 

: (Colon) Range A1:C10 

! (Exclamation Point) Intersection SUM(A1:B6!B5:C12) 

  

18.Differentiate the terms ‘Spreadsheet’ and ‘Worksheet’. [Oct-15] 

Difference between Spreadsheet and Worksheet: 

Spreadsheet Worksheet 

The term ‘spreadsheet’ has come to refer 

specifically to the software packages. 

 

The term ‘worksheet’ refers to the 

files that you create with spreadsheet 

software. 
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19.What are the comparative operators in star office calc? Give example. [Mar-16] 

Comparative Operators:  

� The comparative operators return either true or false. 

 

 

20. How will you insert the special characters in spreadsheet? [Mar-14] 

� For inserting special characters, click the Insert →Special characters from the 

menu bar  

� And select the desired special characters from the Special Character dialog box.  

� For example, select β from the Special Character dialog box and click the OK 

button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Operators Name Example 

= Equal A1=B1 

> Greater than A1>B1 

< Less than A1<B1 

>= Greater than or equal to A1>=B1 

<= Less than or equal to A1<=B1 

<> inequality A1<>B1 
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7.DATABASE 

1.What are the steps involved in data processing? [Mar-07, June-14, June-15, Oct-15] 

Steps involved in data processing: 

Steps involved in data processing are,  

i). Data Collection,  

ii). Data Verification  

iii). Validation of data, and  

iv). Report Generation. 

 

2.Write a note on reports in star office base? [Mar-07, Mar-17] 

Reports: 

� A report is printed information that is assembled by gathering data based on user 

supplied criteria. 

� A report is printed information based on a query that gathers criteria-matching 

data and, in some cases, performs mathematical calculations. 

 

3.Define primary key? Give example. [June-07, Oct-08, Mar-09, Oct-10, Mar-12] 

Primary key: 

� A primary key is a key that uniquely identifies a record in a database table.  

� In relational databases, a primary key can consist of one or more fields. 

� The primary key becomes very important when there are multiple tables, with 

common fields.  

� Every table in StarOffice Base must have a primary key. 

� For example, in employees salary database table, Emp.No. is a primary key, since 

it uniquely identifies an employee record. 

 

4.How will you insert a calc cell range into a text document? [June-07, Mar-15, Oct-16] 

Insert a calc cell range into a text document: 

1. Open a StarOffice Writer (text) document 

2. Open a StarOffice Calc (spreadsheet) that contains the data. 

3. In the spreadsheet, select the cell range that you want to display as a table in 

the text document. 

4. Choose Edit → Copy. 

5. In the text document, choose Edit → Paste special. 

6. In the Paste Special dialog, select DDE link, and then click OK. 

7. The copied cell range will now be displayed in the text document. 
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5.What is data base? [Oct-07, Oct-09, Mar-10, Oct-11] 

Data base: 

� A database is a repository of collections of related data or facts. It arranges them 

in a specific structure. 

� Data in a database in most commonly viewed in one or more two-dimensional 

tables, each consisting of columns and rows.  

 

6.What is DBMS? [Oct-07, Oct-10, Mar-11, Mar-16, June-16] 

DBMS: 

� A DMBS is a program, or collection of programs that allows any number of users 

to access data, modify it (if necessary), and construct simple and complex 

requests to obtain and work with selected records.  

� A DBMS is a software tool that allows users to create database tables and that 

provides access to multiple users. 

7.What is meant by relational data base? [Oct-07] 

Relational data base: 

� A relational structure represents a database made up of a set of related tables.  

� In a relational database, one or more common fields existing in two or more 

tables create a relationship between these tables.  

� The common field or fields are called the Keys. 

� In relational databases, a primary key can consist of one or more fields.  

� The relational database structure is the most prevalent database in today’s 

business organizations. 

 

8.Write a note on filters? (or) What does it mean to ‘filter’ data base records? (or) What is 

filter? What are the types of filter in star office writer? [Mar-08, June-10, June-11, 

Oct-11, June-13, Oct-13, Mar-14, June-16] 

Filters: 

� A filter is also a type of query. It is also used to select and display records, which 

match a certain condition. The remaining records are hidden form the user. 

� Filters let you browse through selected records that meet a set of criteria. 

� StarOffice Base allows you to use two types of filters. They are, 

1. AutoFilter and  

2. Standard Filter (Default Filter). 

9.Write the steps in sorting a data base in star office base? [Mar-08] 

Sorting the data base can be done as follows: 

� Open the table that you want to sort. 

� To sort the records in the ascending order, select the field and click on the Sort 

Ascending icon.   

� To sort the records in the descending order, select the field and click on the Sort 

Descending icon.  
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10.What distinguishes between the information from data? [June-08, June-09, Oct-09, 

Oct-14] 

Data: 

� The term data comes from the word datum, which means a fact.  

� Data are raw facts collected, such as those collected by an organization to record 

transactions. 

Information: 

� Information is defined as a set of processed data that convey the relationship 

between data considered.  

� Information is as group of related data conveying some meaning. 

 

11.Write a note on multiple sorting? [Oct-08, June-12, Mar-12, Mar-13, Mar-14, June-15] 

Multiple sorting: 

� Multiple sorting means sorting on more than one field of a table at the same time.
  

12.How will you copy text and objects between star office application using drag and 

drop? [June-08] 

Copy Data by Drag-and-drop 

� You can use drag-and-drop to copy text and objects between StarOffice 

applications.  

1. Open StarOffice Impress presentation. 

2. Open the Calc spreadsheet that contains the data that you want to copy. 

3. In the spreadsheet, select the cell range that you want to copy. 

4. Just drag-and-drop the selected range into the presentation. (Also use                        

Alt + Tab to open the presentation window) 

 

13.What is the difference between query and filter? [Mar-09, Mar-13] 

Difference between query and filter: 

� The difference between query and filters is that queries can be saved for later use.  

 

14.What is the use of auto filter? [Mar-10] 

Use of auto filter: 

� The AutoFilter icon          is available on the toolbar.  

� Click on this icon to display only the records, which match the value of the 

current field. 

 

15.List and define the three components that make up a data base? [June-10, June-12] 

The three components that make up a data base: 

� The entire collection or related data in one table is referred to as a File or a Table.  

� Each row in a table represents a Record.  

� Each table column represents a Field. 
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16.Write in brief about hierarchical database? [Mar-11, Mar-15, Oct-15] 

Hierarchical database: 

� The hierarchical database structures were primarily used on Main Frame 

computers.  

� The hierarchical database consists of two or more tables. The records are 

organized in a tree like structure by type.  

� The relationship between record types is said to be a parent-child relationship, in 

which any child type relates only to a single parent type. 

 

17.Define: i)Record ii)Field in star office base? [Jun-11] 

Record: 

� Each row in a table represents a Record, which is a set of data for each database entry.  

Field: 

� Each table column represents a Field, which groups each piece or item of data 

among the records into specific categories or types of data. 

18.What is a SQL? [Oct-12] 

SQL: 

� Every DBMS supports a language that is similar to a programming language.  

� This language, called the Structured Query Language (SQL), is designed 

specifically for communicating with a database using statements that are closer to 

English than to programming languages. 

 

19.What is a form in star office Base? [Oct-12, Oct-16] 

A form: 

� A form is simply a screen that displays the fields of a record in a well-spaced out 

manner.  

� A form can be associated with a single table or with multiple tables. 

� Forms are user defined screens that are used to make it easier to enter, view and 

edit the data in a table or a query. 

 

20.What are the categories of the data management task in DBMS? [Oct-13, June-14, 

Mar-17] 

Categories of the data management task: 

� The data management tasks in a DBMS fall into one of the following three 

general categories. 

1. Entering data into the database. 

2. Reordering records in the database. 

3. Obtaining subsets of the data. 
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21.What is a query? And what it is used for? [Oct-14] 

Query: 

� Queries are special views of the data in a table.  

� Queries are user-constructed statements that set conditions for selecting and 

manipulating data in one or more tables and assembling the criteria-matching 

data into information. 

� Queries are used to, 

• Search the database to locate records 

• List a subset of records. 

• Perform calculations. 

• Delete obsolete records 
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 8.INTRODUCTION TO MULTIMEDIA   

1.Write a note on inline sound/ video? [Mar-07, Mar-10, Mar-11, Oct-14, Mar-15] 

Inline Sound and Video: 

� When sound or video is included as part of a web page, then it is called inline 

sound or video.  

� Inline sound or video is plays automatically without giving the viewer any 

control. 

� Sounds and video in multimedia applications can be played “inline” or by using a 

“helper”.  

� You can add inline sound to a web page by using the <bgsound> and the <img> tags. 

 

2.What are the uses of morphing? [Mar-07, June-09, Mar-10, June-10, Mar-12] 

Morphing: 

� Morphing is a technique by which you can blend two or more images to form a 

new image. 

 

3.What is multimedia? [June-07, Oct-08, June-09, Oct-12, June-14, June-15, Oct-15, 

Mar-16] 

Multimedia: 

� Multimedia is a computer-based presentation technique that incorporates text, 

graphics, sound, animations, and video elements. 

� A combination of these elements grabs the viewers’ attention and retains it.  

� The multi-sensory inputs address the different learning needs and styles of 

different users and enhance the entire experience for the user. 

 

4.Write about the types of video compressions? (or) Compare lossless and lossy video 

compression? [June-07, Oct-07, Oct-09, Oct-12, Mar-12, Oct-14, Mar-17] (or) 

Define compression? Write a note on its types? [Mar-11, June-16, Oct-16] 

Compressions: 

� Compression is a technique by which a recurring set of information is identified 

and replaced by a single piece of information. 

� There are two types of video compressions 

1. Lossless compression 

� Retains the exact image throughout the compression. 

2. Lossy compression 

� Provides a comparatively higher ratio of compression but results in some loss of 

quality. 

 

5.What is warping? [Mar-09, Oct-09, June-11, Mar-13, June-13, Oct-13, June-16] 

Warping: 

� Warping is the technique of distorting a single image to represent something else. 
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6.Define morphing and warping. [Oct-10, Oct-11, Mar-14, Mar-16] 

Morphing: 

� Morphing is a technique by which you can blend two or more images to form a 

new image. 

Warping: 

� Warping is the technique of distorting a single image to represent something else. 

 

7.What are the two categories of 2D-Animation? (or) Write a short note on 2D-Animation? 

[Oct-07, June-08, June-10, June-12] 

Two categories of 2D-Animation: 

� Animations can be two- or three-dimensional. Based on how 2-D animations are 

created, they can be broadly classified into the following two categories: 

1. Cel-based animations 

� Cel-based animations consist of multiple drawings, each one a little different 

from the others.  

� When displayed in rapid sequence, these drawing appear to move. 

2. Object-based animations 

� Object-based animations, also referred to as slide or path animations are created 

by moving an object across a screen.  

� This type of animations is usually seen in computer games.  

� For example, a ball moving across the screen. 

 

8.Explain the steps for creating  3D-Animation? [ Mar-08, Oct-11] 

Steps for creating  3D-Animation: 

Creating a 3-D animation is a 3-step process: 

1. Modeling 

2. Animating 

3. Rendering 

� To create a 3-D animation, you have to first create the broad shapes and 

structures of the 3-D objects to be included in the animation.  

� Then, you have to animate these models to define their motion.  

� Finally, you have to render them by giving attributes, such as colors, and 

textures, to the objects. 

 

9.Name the special software used in multimedia content? [June-08] 

Special software used in multimedia content 

� Creating multimedia content requires special software.  

� Some commercial multimedia content development software are Flash, 

Dreamweaver and Maya. 
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10.Expand and explain: (i) MIDI (ii) AVI [Mar-08] 

MIDI: 

� The Musical Instrument Digital Interface or the MIDI format is one that is 

commonly used for transferring music information between electronic music 

devices like synthesizers and sound cards in computers. 

� It was developed in 1982 and its extension is .mid or .midi 

AVI: 

� The Audio Video Interleave or AVI format was developed by Microsoft in 1992. 

It is supported by all computers running the Windows operating systems.  

� Video files stored in the AVI format have the extension .avi 

 

11.Write the full form of    i) MIDI   ii) AIFF iii) MPEG iv) AVI [Oct-08, Mar-15] 

Expansion:  

i) MIDI - Musical Instrument Digital Interface 

ii) AIFF - Audio Interchange File Format 

iii) MPEG - Moving Pictures Experts Group 

iv) AVI - Audio Video Interleave 

 

12.Expand and explain:  AVI   [Mar-09, Mar-17] 

The AVI Format: 

� The Audio Video Interleave or AVI format was developed by Microsoft in 1992.  

� It is supported by all computers running the Windows operating systems and by 

most of the popular browsers.  

� It is a very common format on the Internet.  

� Video files stored in the AVI format have the extension .avi 

 

13.What is plug-in? What is its advantage? [Oct-10]  (or)   Define helper applications. 

Plug-in and its advantage: 

� A helper application, also called as a Plug-in, is a program that can be launched 

by the browser to “help” play sound or video.  

� The advantage of using helper applications is that you can allow the viewer 

control some or all of the player settings.  

� Helper applications can be launched using the <embed>, <applet>, or the 

<object> tags. 

 

14.What do you mean by sampling? (or) What is meant by digital sampling? [June-14] 

Sampling: 

� Before including sounds in an application, you have to convert the analog sound 

waves into a digital format. This conversion of analog sound waves to a digital 

format is called Sampling. 
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15.Expand and explain: i) MPEG ii) AVI [June-11, Oct-13] 

MPEG Format: 

� The MPEG format was developed by the Moving Pictures Experts Group.  

� However, these formats have become one of the most popular format on the 

Internet in recent years.  

� Video files stored in the MPEG format have the extension .mpg or .mpeg 

AVI: 

� The Audio Video Interleave or AVI format was developed by Microsoft in 1992. 

It is supported by all computers running the Windows operating systems. 

�  Video files stored in the AVI format have the extension .avi 

 

16.List any four popular multimedia formats. [Oct-11] 

Popular multimedia formats: 

1. MIDI Format (Musical Instrument Digital Interface) 

2. Real Audio/ Real Video format 

3. AIFF Format (Audio Interchange File Format) 

4. The SND Format 

5. The WAVE Format 

6. The MP3/MPEG Format 

7. AVI Format (Audio Video Interleave) 

8. The Windows Media Format 

9. The QuickTime Format  

10. The Shockwave Format 

 

17.Expand and explain about MIDI? [June-12, Oct-16] 

The MIDI Format: 

� The Musical Instrument Digital Interface or the MIDI format is one that is 

commonly used for transferring music information between electronic music 

devices like synthesizers and sound cards in computers. 

� It was developed in 1982 and is a very flexible format that can be used for a wide 

range of musical applications.  

� The MIDI format cannot contain sounds- it contains only digital notes.  

� For example, a MIDI file that plays for approximately 5 minutes may be only 25 

KB.  

� Sound files in the MIDI format have the extension .mid or .midi 

 

18.Write a note on Quick Time format? [Mar-15, June-15, Oct-15] 

The QuickTime Format 

� The QuickTime format was developed by Apple primarily to store videos.  

� It is a popular format on the Internet but requires the installation of an additional 

component in non-Windows computers.  

� Files in the QuickTime format have the extension .mov 
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19.Write a short note on Shockwave format? [Mar-13] 

The Shockwave Format 

� The Shockwave format was developed by Macromedia and is used to store 

multimedia components created using Flash.  

� This format requires an extra component to play.  

� However, this additional component comes preinstalled with the latest versions 

of Netscape and Internet Explorer.  

� Files in the Shockwave format have the extension .swf 

 

20.Write a note on Real Audio/ Real Video format?  

Real Audio/ Real Video format: 

� The Real Audio/ Real Video Format The RealAudio format was developed by 

Real Networks in 1995 and supports both sound and videos.  

� This format is more popular for transfer of data over the Internet and allows you 

to stream files even over Internet connections with low bandwidths.  

� Files in this format have the extension .rm or .ram 

 

21.Write a note on AIFF format? 

The AIFF Format: 

� The Audio Interchange File Format or AIFF format was developed by Apple.  

� This is not a very popular format as it is neither cross-platform nor is it supported 

by all web browsers.  

� Files in the AIFF format have the extension .aif or .aiff 

 

22.Write a note on WAVE format? 

The WAVE Format 

� The WAVE format was developed by IBM and Microsoft.  

� It is one of the more popular formats as it is not only supported by all computers 

running the Windows operating system, but also by all popular web browsers.  

� Files in the WAVE format have the extension .wav 

 

23.Write a short note on MP3 / MPEG format? 

The MP3/MPEG Format 

� The MPEG format was developed by the Moving Pictures Experts Group.  

� However, these formats have become one of the most popular format on the 

Internet in recent years.  

� The main reason for the popularity of these formats is that they offer good 

compression and high quality.  

� They are also cross-platform and supported by most popular web browsers. 

� Sound files stored in the MP3 format have the extension .mp3, or. mpga  

� Video files stored in the MPEG format have the extension .mpg or .mpeg 
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24.Explain the SND format? 

The SND Format 

� The Sound or SND format was also developed by Apple.  

� Like the AIFF format, the SND files neither cross-platform nor supported by 

popular web browsers.  

� Files in the SND format have the extension .snd 

 

25.Write a note on Windows Media format?    

The Windows Media Format 

� The Windows Media format was developed by Microsoft.  

� It is also one of the very popular formats on the Internet and on computers with 

the Windows operating system.  

� It should be noted that this format requires the installation of an additional 

component in non-Windows computers.  

� Files in the Windows Media format have the extension .wmv 

 

26.Write about GIF and JPEG: 

GIF: 

� GIF (Graphic Interchange Format) is limited to an 8-bit palette. 

� GIF is best suited for storing simple graphic images with relatively few colors. 

However, it is not well fitted for photographic works. 

� A GIF file creates a perfect reproduction of the original, while a JPG does not. 

JPEG: 

� The JPEG (Joint Photographic Experts Group) image files are a lossy format. 

Nearly all digital cameras have the option to save images in JPEG format.  

� The JPEG format supports full color and produces relatively small file sizes.  

� JPG is a lossy compression of the image. 

 

27.What is MMS? 

MMS: 

� The Multimedia Messaging System, or MMS, is an application that allows you to 

send and receive messages over cell phones.  

� These are popularly being used to send and receive jokes, music, ringtones, 

pictures and sometimes even videos. 

 

28.What is virtual reality in multimedia? 

Virtual reality: 

� The various multimedia components are coordinated with a technique called 

virtual reality. 

� They provide an environment which is experienced by users as similar to reality. 
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 9.PRESENTATION  

1.What is the use of master page in presentation? [Mar-07, June-12, Oct-13, June-14, 

June-15] 

Use of master page: 

� This page can be used to specify basic background information that needs to be 

included in all the slides.  

� For example, you can insert a company logo to the master slide and it will appear 

in all the slides. 

 

2.What is meant by handouts view? [Mar-13]  

Handouts view:  

� Allows you to scale the slides so that several slides can fit into a page.  

� This view is typically used when the presentation is to be printed and distributed 

as a handout. 

 

3.How will you create handouts in star office impress? [Mar-07, Mar-12] 

To create handouts: 

� Click the Handout View tab in the view bar. Open the Layout Pane in Tasks Pane.  

� Choose a layout to specify how many slides are printed on a single sheet of paper. 

� To print them, choose File → Print and click Options to define the print settings. 

 

4.What can you with left pane of the presentation window? [June-07] 

Left pane of the presentation window: 

� The Slides pane on the left displays a thumbnail image of the slide and allows 

you to rename, delete, or rearrange them. 

 

5.How to change the slide background? [Oct-07, June-08, June-10, June-11, Oct-13, 

Oct-15, Mar-17] 

Changing Slide Background: 

� You can change the background color or the background fill of the current slide 

or all of the slides in your document.  

� Choose Format  → Page → Background,  Select the background fill from the 

following options. 

i) Color 

ii) Gradient 

iii) Hatching 

iv) Bitmap Image. 
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6.What is meant by “Rehearse timings”? [June-07, Oct-08, June-09, Oct-09, Mar-10, 

June-10, Oct-10, June-12, Mar-13, June-13, Mar-14, Mar-16] 

Rehearse Timings of Slide Changes 

� StarOffice assists you in defining the right rehearse timings for automatic slide 

changes.  

� StarOffice records the display time for each slide, so the next time you play the 

show with automatic slide changes, the timing will be as recorded. 

 

7.How will you record a show with rehearse timings? [Mar-08] 

To record a show with rehearse timings: 

� Open a presentation, and switch to Normal View. 

� Start the show with the Rehearse Timings from Slide Show menu.  

� When it is time to advance to the next slide, click the timer. Continue for all 

slides in your presentation. 

� StarOffice has recorded the display time for each slide. 

� If you want the whole presentation to auto-repeat, open the menu  

Slide Show → Slide Show Settings.  

� Select Auto and then click OK.  

 

8.How will you customize a presentation? [Mar-08]  

Customizing a Presentation: 

� You can create as many custom slides shows as you want. StarOffice Impress 

also allows you to start slide shows from the current slide as well as hide slides 

during a slide show. 

 

9.What is the use of slide sorter view? [June-08] 

Slide Sorter view:  

� Allows you to view miniature images of all the slides in the presentation.  

� This view is also used to rearrange slides. 

 

10.How will you insert picture in presentation? [Oct-07] 

Inserting Pictures in presentation: 

� To Insert a Picture in a slide, choose Insert → Picture → From File or click the 

Insert Picture        icon from the Insert toolbar.  

� Choose the desired picture to be inserted from the open dialog box.  

 

11.What is the use of insert OLE object tool in star office impress? [Oct-08] 

Insert OLE Object: 

� This is used to import objects from other application into a presentation.  

� For example, StarOffice spreadsheet, formulae, text and even Microsoft 

application objects can be inserted. 
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12.How will you rename a slide in star office impress? [Mar-09, Mar-10] 

Renaming Slide: 

� To rename a slide, select the slide, which you want to rename and choose                 

Slide → Rename Slide or right click on the slide and choose Rename Slide. 

13.What is custom animation? [Mar-09, Oct-09, June-11, Mar-12, Mar-14, Mar-16, 

June-16, Mar-17] 

Custom Animation:  

� This page displays various options that allow you to add or modify animation 

effects to elements of a slide. 

14.What is slide transition? [June-09, Mar-11, June-13, Mar-15] 

Slide Transition:  

� This page displays various transition effects that can be attached to a slide along 

with other options that allow you to control the transition of the slides.  

� Note that you can have a different transition for each slide in the presentation. 

 

15.How to insert, delete, rename slide in presentation? [Mar-11, Mar-15, June-15, Oct-16] 

Inserting Slide: 

� To insert a slide, click the Slide button in the Presentation toolbar or choose 

Insert → Slide from the menu bar.  

� The new slide uses the page layout of the previous slide. 

Deleting Slide: 

� If you want to delete a slide, select the slide, which you want to delete in the 

Slides Pane and press Delete key or right click on the slide, and choose Delete 

Slide. 

Renaming Slide: 

� To rename a slide, select the slide, which you want to rename and choose                 

Slide → Rename Slide or right click on the slide and choose Rename Slide. 

16.How to create custom slide show? [Oct-11, Oct-16] 

To create a custom slide show: 

� Choose Slide Show → Custom Slide Shows, and then click New. 

� Enter a name for your slide show in the Name box. 

� Under Existing Slides, select the slides you want to add to your slide show, and 

click the >> button.  

� You can change the order of the slides in your custom slide show. 

� And Click Ok button. 

17.What is the use of notes view & normal view in presentation? [Oct-12] 

Normal view:  

� It allows you to create and edit slides 

Notes view:  

� Allows you to add notes to the slides or view any existing notes for the slide.  

� Notes are typically used by a presenter to add additional information to a slide. 
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18.What is the use of master slide in presentation? [Oct-12] 

Use of master slide in presentation: 

� A master slide determines the text formatting style for title, outline and the 

background design for individual slides, or for all of the slides in a presentation.  

� You can change the appearance of a master slide by applying a new slide design. 

  

19.How will you hide a slide in staroffice impress? [June-16] 

To hide a slide: 

� Select the slide(s) that you want to hide in the slide show. 

� Choose Slide Show  → Show/Hide Slide. 

 

20.Write the steps to show a hidden slide in star office impress? [June-14, Oct-15] 

To show a hidden slide: 

� Select the slide(s) that you want to hide form the Slides Pane. 

� Choose Slide Show → Show/Hide Slide to show the slide in the slide show. 

 

21.How to start a custom slide show? [Oct-16] 

To start a custom slide show: 

� Choose Slide Show → Custom Slide Show. 

� Select the slide show you want to start from the list. 

� Click Start. 

 

22.How to print a slide to fit a paper size? [Oct-14] 

To print a slide: 

� You can reduce the size of a slide when you print, so that the slide can fit on a 

printed page. 

� Open the document that you want to print. In Normal View, choose Format → 

Page, and then Page tab. 

� In Layout settings area, select the Fit object to paper format check box. 

� In the Paper format area, select a Format. Click OK. 

� Now the slide is resized to fit the printed page. 
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1.AN INTRODUCTION TO STAROFFICE WRITER 
II. Five mark questions:  

1. Explain the different ways of selecting text in star office writer document.  (or) How 

will you select the required portion of the text in a document using mouse, keyboard 

and shortcuts? [Oct-08, Oct-09, June-11, June-13, Oct-13, June-15, Mar-17] 

Selecting Text: 

� Even though the document is built up by typing one character at a time, while 

editing and formatting one always work with words, lines, paragraphs and 

sometimes with the whole document.  

� For this purpose one should learn how to select the text. Once the text is selected, 

change can be made to that text.  

� The text can be moved, copied and made as bold. The font and colour of the text 

can also be changed.  

� For selecting text the mouse or the keyboard can be used. 

Selecting Text with Mouse 

Following steps are to be followed: 

     1. Insertion point is moved to the start of the text to be selected. 

     2. The left mouse button should be clicked, held down and dragged across the text to  

 be selected. 

     3. When the intended text is selected, the mouse button should be released. 

     4. To unselect the wrongly selected text a click should be made outside the selected  

         text. 

 

Selecting Text with Keyboard 

Following are the steps to be followed: 

     1. Insertion point is moved to the start of the text to be selected. 

     2. The Shift key is pressed down and the movement keys are used to highlight the  

 required text. 

     3. When the Shift key is released, the text is selected. 

 

Selection Shortcuts 

The following shortcuts can also be used for selection. 

Action to be performed To select what 

Double click on a word  To select a word  

Click once next to the line  To select the particular line 

Press Ctrl + A  To select the entire Document  
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2. Give the steps involved for replacing a word with another word in a given text and 

explain.  (or) Write the steps to be followed to find and replace a given text (or) How 

will you find and replace a given word in star office writer document? [Mar-07, Mar-

08, June-08, June-09, Oct-11, Oct-12, Mar-13, June-14, Mar-16, Oct-16] 

 

Finding and Replacing Text: 

� You can use the Find & Replace feature in StarOffice Writer to search for and to 

replace words in a text document. 

To Find and Replace Text 

1. Choose Edit → Find & Replace. The Find & Replace dialog box appears on 

the screen. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. In the Search for box, type the text that you want to find in your document. 

3. In the Replace with box, enter the replacement word or phrase. 

4. Click Find to start the search. 

5. When Writer finds the first instance of the word or phrase, do one of the  

    following: 

        • To replace the found instance of the text with what you entered in the  

 Replace  with box, click Replace. 

        • To replace all instances of the text with what you entered in the Replace  

 with box, click Replace All. 

         • To skip the found text and to continue the search, click Find again. 

6. Click Close when you have finished the search. 
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2.TEXT FORMATTING 
 

1. How will you indent a given text by using paragraph dialog box? [Mar-09, Mar-12, 

June-12]  (or)   How will you indent a given text by using paragraph dialog box and by 

using formatting tool bar? [Mar-16] 

Indenting Text with the Toolbar 

� If a left indent is required - useful for setting off a paragraph from the main body 

text - the toolbar can be used to set the indent. 

� Click the Increase Indent          icon; the paragraph is indented 1/2 inch from the 

left margin. The button again can be clicked to increase the indent.  

� Each time the button is clicked, the paragraph is indented another 1/2 inch. 

� If the indent is too much or if one wants to undo the indent, the Decrease Indent    

           icon is clicked to decrease of undo the indents. 

Indenting Text with the Paragraph Dialog Box 

1. Move the insertion point to the beginning of the paragraph to be indented. To 

indent several paragraphs, select those paragraphs. 

2. Select Format → Paragraph command. Now paragraph dialog box appears on 

the screen. 

3. Click the Indents & Spacing tab in the Paragraph dialog box 

4. Do any of the following. 

• To indent from the left, type the amount to be indented in the Before text spin 

box or use the spin arrows to select a value. 

• To indent from the right, type the amount to be indented in the After text spin 

box or use the spin arrows to select a value. 

• Click the OK button. 

� The First line option can be used to indent the line of the paragraph. Using the 

spin arrows, if a positive value is specified, the first line will be indented.  

� A negative value will result in a hanging indent; that is, the first line will hang 

outside the paragraph. 
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2. What are the various types of paragraph alignment that can be made? Explain. [Oct-07] 

Paragraph Alignment: 

� In addition to formatting individual chunks of text, one can also format the 

paragraphs. One of the most common changes is to change the alignment of a 

paragraph. 

� A paragraph is any text followed by a hard return. A hard return is inserted every 

time when Enter is pressed.  

� Soft returns are inserted as line breaks by StarOffice Writer and are adjusted 

when text is added or deleted.  

� A single line, for instance, can be a paragraph. One can apply the paragraph 

formatting options to a single paragraph or to several paragraphs 

� Also, each time Enter is pressed, the paragraph options for that paragraph are 

carried down to the next paragraph.  

� When typing in StarOffice Writer, all text is left aligned, and the right margin is 

ragged or uneven. 

� Four types of alignment can be selected, and the best way to make a change is to 

use the Formatting toolbar. Following steps are used to align the text: 

1. To change the alignment of one paragraph, first click within that paragraph. To 

change the alignment of several paragraphs, select the ones needing change. 

2. Do one of the following 

Click the icon        to left align text.         

Click the icon        to right align text.         

Click the icon        to justify text.         

Click the icon        to center text.         

The following keyboard shortcuts can also be used to change the alignment. 

To make the text as Left-aligned press Ctrl + L   

To make the text as Right-aligned press Ctrl + R         

To make the text as Centered press Ctrl + E         

To make the text as Justified press Ctrl + J   
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3. How will you create a numbered list and bullet list in StarOffice writer document? 

[Mar-10, June-10, Oct-10, Mar-14, Oct-14, Oct-15] 

Creating Bullets and Numbered List 

� When the document presents a matter using text in the form of long paragraphs 

the reader may not be able to quickly notice the important points or messages.  

� For this purpose bullets and numbers are used to list the important points and 

messages. 

� StarOffice Writer automatically numbers all the items in a list, and the text is 

indented. 

Following steps are used to create a Bulleted list: 

� Select the text that to which bullets are to be added. The StarOffice Writer will 

add bullets to each paragraph within the selection, and not to each line.  

� StarOffice Writer will add bullets to any blank lines within the selection. 

There are two ways to add the bullets for the paragraph, 

1. Click on the Bullets icon         from the formatting tool bar, StarOffice Writer 

creates a bulleted list 

2. Choose Format → Bullets and Numbering, command can also be add various 

types of bullets to the paragraph. 

Following steps are used to create a Numbered list: 

� Select the text that to which numbers are to be added. The StarOffice Writer will 

add numbers to each paragraph within the selection, and not to each line.  

� StarOffice Writer will add numbers to any blank lines within the selection. 

There are two ways to add the numbers for the paragraph, 

1. Click on the Numbering icon         from the formatting tool bar, StarOffice Writer 

creates a  Numbered list 

2. Choose Format → Bullets and Numbering, command can also be add various 

types of Numbers to the  paragraph. 

Removing the Bullets or Numbers 

� To remove bullets from a list, the list is selected and the Bullets button is clicked 

again.  

� To remove numbers for a list, select the list and click the Numbering button. 
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4. What are the formatting changes that can be made with respect to the fonts?  

Formatting Options 

� StarOffice Writer offers a number of choices for formatting such as bold or 

italics, and defining the font, type, and font size.  

� Bold, italic or underlined are the most common types of text formatting. 

� Almost all the formatting options are available under Format menu.  

Click  to make text Bold. 

Click  to make text Italic. 

Click  to make text Underlined. 

� Alternatively Ctrl + B, Ctrl + I and Ctrl + U keys can be used to makethe 

selected text bold, italic and underlined respectively. 

� The same can also be achieved by clicking on Format → Character and then 

selecting an option from the Typeface list box. 

Changing the Fonts 

� A font is a set of characters and numbers in a certain style. Each font looks 

different from other fonts.  

� Some fonts, like the Times New Roman, look professional and are suited for 

business documents. 

� Some fonts, like FAJITA, are decorative. Some fonts, like Symbol and 

Wingdings, are actually sets of symbols.  

Method 

� Click the down arrow in the Fonts Combo box                                       of font tab 

in Character dialog box. 

� The text changes to the selected font type 

Changing the Font Size 

� The size of the text is also important.  

� The size of a font is measured in points, and there are 72 points to an inch.  

Method 

� Click the down arrow in the Size combo box               of Fonts tab in Character 

dialog box. 

� The text changes to the selected font size 

Changing the Font Colour 

� A different colour for selected text can be used. Colour printers are becoming 

more and more popular.  

� In the absence of a colour printer, the document will be displayed on screen in 

colour.  

� But these changes will be printed as shades of gray on a black-and-white printer. 

Method 

� To use a different text color, select the text and click the arrow in the Font 

Colour icon         . A colour palette is displayed from which the required colour 

can be selected         
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3.CORRECTING SPELLING MISTAKES 

1. How would you carry out the spell check after the entire document is typed? [June-07,       

June-09, Oct-10, Mar-11, Mar-12, June-13, Mar-14, June-14, Oct-15] 

Checking the Spelling after the Document is Typed 

The following steps are used for a spell check. 

� Tools → Spelling → Check is selected or        is clicked. To check a part of the 

document only that portion is selected.  

� The F7 key may also be pressed to select the spelling command. 

 

 

 

 

 

 

 

 

 

 

 

� Not in dictionary text area displays the misspelled word and the Suggestions list 

displays any alternative spellings. 

Any of the following can be done: 

� To skip this occurrence but stop on the next one. Ignore Once button is clicked. 

To skip all occurrences of this word. Ignore All button is clicked. 

� To replace the word with one of the selected spellings, in the suggestions list that 

spelling is clicked, and Change button is clicked to change this occurrence and 

Change All button is clicked to replace all occurrences of the world. 

� If none of the replacements is correct, correction can be made manually in the 

Not in dictionary text area. Add button is clicked to add the word to the 

dictionary. 
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2. How will you add an entry to the auto correct list in star office writer? [Mar-08, June-

16] 

AutoCorrect Option 

� In addition to flagging some words, StarOffice Writer will automatically correct 

some spelling mistakes.  

� StarOffice Writer recognises some common misspellings and typographical 

mistakes and makes the replacement automatically.  

� For instance, if a word is typed as “teh”, StarOffice Writer automatically replaces 

this with the correct word “the”.  

� In addition to the ones StarOffice Writer automatically corrects, the user can add 

other words to the list.  

Add a word in the auto correct list: 

� If the error and its correction are to be added to the Auto Correct list the 

following command is used Tools → AutoCorrect,  now auto correct dialog box 

appears on the screen. 

 

 

 

 

 

 

 

 

 

 

 

 

� In this box, with the Replace tab selected the word to be replaced is typed in the 

Replace text box and the replacement word in the With text box.  

� When the same mistake is made StarOffice Writer will automatically replace the 

misspelled word with the correct spelling. 
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4.WORKING WITH TABLES 
 

1. Draw and explain the various function icons in the table formatting toolbar in a star 

office writer document? [Mar-07, June-07, Oct-07, Oct-08, Oct-09, Mar-10, Mar-11, 

Oct-12, Mar-13, Mar-15, Oct-16, Mar-17] 

Table Formatting Toolbar 

� Once a click is made inside a table a floating toolbar for tables appears at the top 

of the screen.  

 

 

 

 

 

                        - Table Fixed      

                   - Table Fixed, Proportional  

                         - Table, Variable 

               - Merge Cells - This icon is used to combine two or more cell into a  

                                         single cell. 

               - Split Cells - This icon is used to split a cell into two or more cells. 

                    - Optimise - Clicking on this icon displays a pop up menu with options like 

           Space columns equally, Space rows equally, Optimum row 

            height and Optimum column width. 

            - Inserting Row - This icon is used to insert a row below the current row. 

           - Inserting Column - This icon inserts a column to the right of the current  

                                               column. 

           - Delete Row - This icon deletes the current row from the table. 

            - Delete Column - This icon deletes the current Column from the table. 

                       - Borders - This icon displays a floating toolbar with different border 

                                       option for  the table. 

                       -  Line Style - This icon is used to choose the style of line to be used for  

                                              the border. 

                  - Border Colour - Clicking on this icon displays a palette of colours that 

                                                can be used as a border colour for the table. 
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2. How will you add and delete rows, columns in a star office writer table? [June-12, 

June-16] 

Creating a Simple Table 

� Table → Insert → Table command is used to create the simple table 

� StarOffice Writer displays the table as a grid with the specified number of 

columns and rows. 

� By default each cell includes a border. 

Adding Rows: 

� The simplest way to add a row is to press Tab in the last row of the table.  

� Choose Table → Insert → Rows command can be used to insert more than one 

row in a table. 

� Also click the          icon is used to insert a row below the current row. 

Adding Columns: 

� Choose Table → Insert → Columns command can be used to insert more than 

one column in a table. 

� Also click the         icon inserts a column to the right of the current column. 

Deleting Rows: 

� Choose Table → Delete → Rows command can be used to deleting the rows. 

� Also click the         icon deletes the current row from the table. 

Deleting Columns: 

� Choose Table → Delete → Columns command can be used to deleting the 

columns. 

�  Also click the        icon deletes the current Column from the table. 

 

3. Explain the methods of changing margins. (or) Write in detail about how to change the 

margins using page style dialog box and ruler. [Mar-09, June-10, June-11, Oct-11, Oct-13] 

Changing the Margin 

� Margins control how close StarOffice Writer prints to the edge of the page. 

� The default margins are 1inch top and bottom margins and 1.25 inches left and 

right margins.  

� These margins work fine for most of the documents.  

Using any one of the following methods, margins can be changed, 

1. Page Style Dialog Box 

2. Changing Margins Using Rulers 

Page Style Dialog Box 

� If the user knows the exact value for the margins then the page style dialog box 

can be used to make a change.  

The following steps are used: 

� Format → Page command is selected. Page style dialog box appears on the screen. 

� Click the Page tab, if necessary. 

� In Margins group, type the new values in the spin boxes or use the spin arrows to 

change the value. 
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� Click the OK button. 

� Use the Page Preview option in the File menu can be used to see the change. 

Changing Margins Using Rulers: 

� If the user is not having the exact value for the margins then the Ruler option on 

the View menu can be used to change the margins. 

Following steps are used in this method: 

� If the ruler is not displayed in the screen, View → Ruler option is clicked. 

� The gray area of the ruler indicates the margin’s top area. 

� The mouse pointer is then moved in between the gray and white area of the ruler. 

� When the pointer is in the right spot, it changes into a line with arrows on both sides. 

� The margin guide is dragged to a new location. 

 

4. Explain creating header and footer and adding remarks and insert page numbers in a 

text document. [June-08] 

HEADER AND FOOTER: 

� Header is an area at the top of page. 

� Footer is an area at the bottom of the page. 

� Header and footer are some references remarks added at every page of the 

document of the top and bottom margins respectively.  

To Create header: 

� To create a header, the Header tab on the Page Style dialog box can be used.  

� In this dialog box, the Header on check box is clicked.  

� Four spin boxes are also displayed. In those spin boxes the distance of the header 

from the text area, the header height, the distance from the left margin and the 

right margin are entered. 

To Create Footer: 

� To create a footer, the Footer tab on the Page Style dialog box can be used.  

� In this dialog box, the Footer on check box is clicked.  

� Four spin boxes are also displayed. In those spin boxes the distance of the footer 

from the text area, the footer height, the distance from the left margin and the 

right margin are entered. 

To insert page numbers in footer: 

� Click in the header or footer area. clicking on Insert → Fields → Page Number 

will insert page numbers on every page. Normal text can also be included in the 

header and footer. 
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6.SPREADSHEET 
 

1. What are functions? How can you use them in your worksheet? Explain with an 

example? [Mar-07, Oct-07, Mar-08, Oct-08, June-09, Oct-09, June-12, Mar-13] 

Using Functions: 

� StarOffice Calc has a wide variety of functions that allow you to perform several 

frequently done calculations.  

� Functions are predefined formulae that are available in StarOffice Calc. 

To insert a function: 

� To select a function, go to Insert menu and Select the Function option. The 

Function Wizard dialog box appears.  

� A list of all functions is displayed in the Function box when All is selected in the 

Category box.  

 

 

 

 

 

 

 

 

 

 

 

To select a function: 

� Select the category in the Category box. 

� Scroll down the list to find the function you want. Click once on the function 

name to see a short description of that function on the right side of the window. 

Double – click on it to insert it into the worksheet. 

� The Function Wizard shortcut icon on the formula bar can also be used to 

select and insert functions. 

For example,  

� To insert the SQRT function, place the cursor in the cell where you want to insert 

the function and click on the Function Wizard icon.  

� Select Mathematical from Category.  

� Select the SQRT function from the list of functions, which appears by double 

clicking on it.  

� Enter the number 64. When you click on OK, the result is displayed in the cell in 

the worksheet is 8. 

�        One of the most commonly used function is the Sum function. This function 

calculates the sum of a given set of numbers.  
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2. Explain the procedure to insert a chart in a worksheet?  (or)  What spread sheet feature 

allows you to represent data visually as a data – analysis tool?  (or) Describe the steps 

to be followed for presenting the data in the worksheet in the form of charts  (or)  

Explain the procedure to be followed to draw chart. [Mar-07, Oct-08, Oct-09, Mar-10, 

Oct-11] 

Working With Charts: 

� One of the most popular features of StarOffice Calc software is the ability to 

generate charts based on numeric data.  

� The purpose of chart is to visually present the data for easy understanding.  

To draw a chart, follow the procedure given below: 

� Select the data you want to chart. 

� Click on Insert → Chart or click on the Insert Chart icon            

� The cursor becomes a + sign with a small picture of the graph. Place this cursor 

where you want to insert the chart and click. 

� The Auto format Chart window appears on the screen. 

 

 

 

 

 

 

 

 

 

 

 

 

� It prompts you to enter the area in the worksheet to be charted. Enter the range as 

C3 : F7 and click Next.  

� The next window displays the different types of charts that can be created along 

with a preview of each. Select the type of chart in which you want to present the 

data. The preview window shows the chart. Click on Next. 

� For each type of the chart (say Pie, Bar, Column, etc.), there are different formats 

available.  

� These formats are displayed in the next window a preview of the each format is 

also displayed. Here, select the desired format. Click on Next. 

� In the next window, you have provisions to give a Title for the chart, Titles for X 

and Y axes and legends. 

� Click on Create. Now, your worksheet will display with a chart. 
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3. How can you generate a series of values? Explain with an example? (or) Explain the fill 

command in StarOffice calc? [June-07, June-09, June-10, Oct-10, Mar-11, June-11, 

Oct-11, Mar-12, Oct-13] 

Fill Command: 

� AutoFill automatically generates a data series based on a defined pattern. 

1. On a sheet, click in cell, and type a number. 

2. Drag the fill handle in the bottom right corner of the cell across the cells that 

you want to fill, and release the mouse button. 

� You can also use the Fill command to generate a series of data directly from the 

values of the selected cells.  

� First, select the cells of the worksheet that you want to fill.  

� Choose the command Edit → Fill → Series. Select the type of series from the 

options that appear on the screen. 

 

 

 

 

 

 

 

 

 

 

 

For example, select the range A1:D6 in the worksheet. 

Click on Edit →Fill → Series. Choose 

2 as your Start value 

2 as your Increment 

Growth as the Type, and 

Down as the Direction. 

Now, click on OK and you will see the worksheet filled as shown in below. 
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4. How will you insert cells, rows and columns in staroffice calc?  (or) How will we insert 

an empty cell in a worksheet? [Mar-08, June-08, Mar-09, June-11]   

Inserting Cells, Rows and Columns: 

� Often after creating a worksheet, you find the need to insert a row or column in 
the worksheet.  

� StarOffice Calc allows you to insert one or more cells, rows and column. 
� Click the Insert Cell from View → Toolbar menu. A floating toolbar with four 

icons appears. These icons are  
1. Insert Cells Down,  

2. Insert Cells Right,  

3. Insert Rows and  

4. Insert Columns icons. 

 Insert Cells Down: 

�              In order to insert an empty cell in a column and move the existing cells 

down, place the cursor in the cell where you want to insert the new cell and click 

on the Insert Cells Down icon.  

� For example, to insert a new cell in the worksheet, select the cell C3 and click the 

Insert Cells Down icon. The new cell will insert and existing cell C3 is move to 

one cell down. 

The output screen as follows. 

 A B C D E 

1 Name Tamil English Maths  

2 Senthil 167 134 156  

3 Karan 150  187  

4 Kumar 174 179 179  

5   183   

Insert Cells Right:  

�   In order to shift the content of a cell to the right and to create an empty cell, 

select the cell and click the Insert Cells Right icon.  

� For example, to insert a new cell in the worksheet, select the cell C3 and click the 

Insert Cells Right icon. The new cell will insert and existing cell C3 is move to 

one cell Right. 

The output screen as follows. 

 A B C D E 

1 Name Tamil English Maths  

2 Senthil 167 134 156  

3 Karan 150  163 187 

4 Kumar 174 183 179  

5      

Insert Rows:  

�          In order to insert an empty row in a worksheet, select the row where you 

want to insert the new row and click the Insert Rows icon.  
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� For example, to insert a new row between 3rd and 4th rows in the worksheet select 

the 4th row and click the Insert Rows icon. The new row will insert and 4th row 

will move to the down. 

The output screen is shown below. 

 A B C D E 

1 Name Tamil English Maths  

2 Senthil 167 134 156  

3 Karan 150 163 187  

4      

5 Kumar 174 183 179  

Insert Columns:  

�         In order to insert a column, select the column where you want to insert and 

click the Insert Columns icon.  

� For example, to insert a new column between C and D columns in the worksheet, 

select the column D and click the insert columns icon. The New column will 

insert and D column will move to the right. 

The output screen is shown below. 

 A B C D E 

1 Name Tamil English  Maths 

2 Senthil 167 134  156 

3 Karan 150 163  187 

4 Kumar 174 183  179 

5      

 

5. Write the advantages of using electronic spread sheet?  (or)  In which ways the 

electronic spreadsheet offer several advantages over the manual one? (or) Define 

briefly a spreadsheet and list some of the main advantages of electronic spreadsheets. 

[June-07, Oct-10, June-12, Oct-12] 

Advantages of using Electronic spreadsheets: 

� Calculations are automated through the built-in mathematical, financial and 

statistical functions. 

� Accurate results to any desired level of decimal points are possible 

� Worksheets can be quite big in size 

� Any part of the worksheet can be viewed or edited. 

� Worksheet can be saved and retrieved later. 

� Any part or whole of an existing worksheet can be merged with any existing or 

new worksheet. 

� Any part or whole of the worksheet can be printed in a desired format. 

� Worksheet data can be viewed in the form of graphs or charts 

� The worksheet information can be transferred to any database or word processing 

software. 
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6. What are the various formatting options available in staroffice calc? (or) How to format 

the worksheet? [June-08, Mar-09, Mar-12, June-13] 

Listed below are some of the formatting options available in StarOffice Calc. 

   - This is the Bold icon and is used to display data in bold. To use this icon,  

      highlight the cells and click on the icon. 

             -  This icon is used to display the data in italics. 

    - This is used to underline the data in highlighted cells. 

                           - This is the Change Font icon. This icon displays list of fonts 

                              that can be used. Select the font by clicking on it. 

      - This icon is used to change the font size of the data. To do so, select the 

         data and click on this icon. 

      - This is the Font Colour icon. This can be used to change the font colour. 

                    - These are the Align Left, Align Center, Align Right and Justify  

                       icons. They are used to align the contents of cells. 

     - This is the Number Format: Currency icon. Clicking on this will display  

        the contents of the selected cells in currency format, that is with a $ in front  

         and with two decimal digits. 

 - This is the Number Format: Percent icon. Clicking on this icon will  

   display the current contents in percentage format. Note that it multiplies  

    the contents of the cell by 100 and displays the result with 2 decimals. 

 

 - This is the Number Format: Standard icon. Clicking on this icon will 

    display the contents of the selected cells in default format. 

            - These are the Number Format: Add Decimal and Number Format: 

               Delete Decimal icons. They are used to increase or decrease the number  

               of decimal digits that are to be displayed in the selected cells. 

� The Format menu can also be used to format cells. To do so, select the cells you 
want to format and click on Format → Cells. 
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7. What are the various icons in the insert object floating tool bar of worksheet? Mention 

their functions and uses. [Oct-07, Mar-11, Oct-12, Mar-13, June-13, Oct-13] 

Inserting Objects: 

� StarOffice Calc provides tools for inserting objects like charts, images from 

image editor, formula, etc. in a worksheet.  

� For this purpose, click on the Insert Object from View → Toolbar.  

A floating toolbar appears with the following icons in the order listed below: 

 

 

 

1. Insert Chart Icon 

2. Insert Formula Icon 

3. Insert Floating Frame Icon 

4. Insert Movie and Sound Icon 

5. Insert OLE Object Icon 

6. Insert Applet Icon 

Insert Chart Icon 

� This icon is used for presenting the data in the worksheet in from of charts of 

different kinds such as Bar Chart, Pie Chart, Lines, XY plot, etc.  

Insert Formula Icon 

� This icon is used for inserting a formula in the worksheet for performing 

calculations. 

Insert Floating Frame Icon 

� This icon provides to generate a scrolling screen within a worksheet. 

Insert Movie and Sound Icon 

� This icon is used to insert sound or video files into the current worksheet. 

Insert OLE Object Icon 

� This icon is used to insert objects from other application into a worksheet. 

Insert Applet Icon 

� This icon is used to import Applets written in Java programming language into 

the worksheet. 
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8. Explain the different types of operators in star office calc? 

Types of operators in star office calc: 

� Various types of operators available in staroffice calc. 

Arithmetic Operators: 

� These operators return numerical results 

Operator Name Example 

+ (Plus) Addition 1+1 

- (Minus) Subtraction 1-1 

- (Minus) Negation -5 

*(Asterisk) Multiplication 2*2 

/ (Slash) Division 9/3 

%(percent) Percent 15% 

^ Exponentiation 3^2 

Comparative operators 

� These operators return either true or false. 

Operator Name Example 

= Equal A1=B1 

> Greater than A1>B1 

< Less than A1<B1 

>= Greater than or equal to A1>=B1 

<= Less than or equal to A1<=B1 

<> Inequality A1<>B1 

Text operators 

� The operator combines sections of text to the entire text. 

Operator Name Example 

& )AND* Text Operator 
“Star” & “Office” yields 

StarOffice” 

Reference Operators 

� These operators combine areas. 

Operator Name Example 

;!)Colon* Range A1:C108  

"!)Exclamation*
! !

Intersection SUM(A1:B6!B5:C12) 

� When arithmetic operators are used in formulae, StarOffice Calc calculates the 

results using the rules of precedence followed in Mathematics. The order is as 

follows: 

1. Exponentiation (∧) 

2. Negation (-) 

3. Multiplication and Division (*, /) 

4. Addition and Subtraction (+, -) 
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7.DATABASE 

1. Explain different database types. (or) Explain the classifications of database? [June-07, 

June-12, Mar-13, June-13] 

Database Types: 

� Based on the conceptual structures, the databases can be classified as follows: 

1. Flat – File database 

2. Relational database 

3. Hierarchical database 

4. Network database 

5. Object-Oriented database 

Flat – File Database 

� A database file that consists of a single data table is a Flat-file database.  

� Flat-file database can be quite useful for certain single user or small-group 

situations, especially for maintaining lists such as address lists or inventories.  

� Data that is stored, managed, and manipulated in spreadsheet is another example 

of a flat-file database. 

Relational database 

� A relational structure represents a database made up of a set of related tables.  

� In a relational database, one or more common fields existing in two or more 

tables create a relationship between these tables. The common field or fields are 

called the Keys. 

� A primary key is a key that uniquely identifies a record in a database table.  

� In relational databases, a primary key can consist of one or more fields.  

� The relational database structure is the most prevalent database in today’s 

business organizations. 

Hierarchical database 

� The hierarchical database structures were primarily used on Main Frame 
computers.  

� In hierarchical databases, records are organized in a tree like structure by type.  

� The relationship between record types is said to be a parent-child relationship, in 

which any child type relates only to a single parent type. 

Network database 

� The Network database is very similar to the hierarchical structure except that any 

one record type can relate to any number of other record types. 

Object Oriented database 

� An Object Oriented database is a newer structure that has been generating a great 
deal of interest in recent years.  

� The object oriented structure groups data items and their associated 
characteristics, attributes, and procedures into complex items called objects.  

� An object is defined by its characteristics, attributes and procedures.  
� A procedure refers to the processing or handling that can be associated to the 

object. 
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2. Explain manipulation of a database?   (or) What are the ways of manipulating a 

database? [Mar-08, June-08, June-09, June-10, Mar-11, Mar-12, Oct-12, June-13] 

Manipulation of a Database: 

� We may manipulate the database in one or more of the following ways: 

1. Searching 

2. Sorting 

3. Merging 

4. Performing Calculations on data 

5. Filtering 

6. Editing the database 

7. Report Generation 

Searching 

� Searching is a process to select a desired specific data from a database.  

� For instance, you want to select the student ranking first in a class with respect to 

the total marks.  

� Searching is done using database commands on the relevant fields. 

Sorting 

� Sorting is the process of arranging the data in a table in some order.  

� In the case of the student database, you may sort the passed students and failed 

students separately or you may sort the students in the ascending or descending 

order of their total marks, and so on. 

Merging 

� Merging is a process of joining data from two or more tables of the same or 

different databases.  

� For example, in a student database, you may have mark lists for different classes. 

You want to prepare one table that shows all the first ranking students of each 

class.  

Performing Calculations on data 

� You may do any kind of arithmetic calculations on the data stored in the 

database.  

� For example, to obtain the total marks of all the subjects of a student, you may 

add the marks in the concerned fields of the database and store them in a separate 

field. 

Filtering 

� There are times when viewing the entire table is unwieldy. Filter is a way of 

limiting the information that appears on screen. 

� Filters are a feature for displaying and browsing a selected list or subset of 

records from a table.  

� The visible records satisfy the condition that the user sets. Those that do not 

satisfy the condition are hidden. 
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Editing the Database 

� Editing is a process of performing corrections on the existing data, deleting the 

existing data, field(s), or record(s), adding new data, field(s), record(s) or 

changing the format of the database, and so on. 

Report Generation 

� You may generate any desired report, from the data of the database.  

� For example, in the case of student database, you may generate a report of all the 

students who have scored marks less than the minimum marks required for a 

pass, and another report that gives the list of passed students, and so on. 

 

 

3. What are the advantages of (EDP) Electronic Computerized Data Processing? [Mar-10] 

Advantages of Computerised Data Processing: 

� Once we collect and enter the data into a computer system, We can perform other 

operations with less manual labour. So, manpower is considerable saved. 

� Though it takes some time to develop, test and put the required computer 

programs to use, the processing speed is fast, reducing the processing time, in 

certain cases, from man-years and man-months to minutes and seconds. 

� The chances of errors are less in computerized data processing. 

� We can store large amount of the data and information in the computer storage 

medium, which is compact. Hence, we need not store bundles of paper records, 

thus saving space. 

� Today computer networks are so common that we can share data and resources 

from one computer system to the other at a very fast speed and with very little 

effort, as in the case of railway and airline reservation systems. 

� It is easy to edit the data including correction, changes and modifications. 

� Computerized database is highly effective for searching, sorting and merging 

files and for other data manipulation activities. 

 

4. Explain how to create form using star office base? (or) Explain the form designing and 

describe how it is used? [Oct-11] 

A form: 

� A form is simply a screen that displays the fields of a record in a well-spaced out 

manner.  

� A form can be associated with a single table or with multiple tables. 

To design a form in Star Base, follow the procedure given below: 

1. Select Form icon from the <Database> pane and then select ‘Use Wizard to 

Create Form’.  

2. Select the table or query for which the form is to be designed. The field names 

of the selected table or query are displayed in the ‘Available fields’ text area. 

3. Select the field names that you would like to include in the form using the > 

or >> button and then click the Next button. 
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4. Next, StarOffice Base displays ‘Set up a subform’ window. Select the ‘Add 

Subform’ checkbox, if you want to insert another form within this form else 

click Next. Click on the Style icon and click on the Next button. 

5. The next window is for selecting the data entry mode.  

6. The next window Form Wizard – Apply Styles specifies the form style. The 

page style decides the font attributes like font type, size color and background 

of the text in the form. 

7. Next, Set the name of the form window asking for a name for the form. Type 

the name of the form and click the Finish button. 

 

5. Explain filter and its types with examples. [Oct-07]  

Filters 

� A filter is also a type of query. It is also used to select and display records, which 

match a certain condition. The remaining records are hidden form the user.  

� The difference between query and filters is that queries can be saved for later use.  

� StarOffice Base allows you to use two types of filters. They are  

1. AutoFilter and  

2. Standard Filter. 

AutoFilter 

� The AutoFilter icon          is available on the toolbar. Click on this icon to 

display only the records, which match the value of the current field. 

Standard Filter 

� Filter used with a condition called Default Filter. The condition can be specified 

by clicking on the Standard Filter icon         on the toolbar. 

For  example,  

• Open an existing query form the Queries pane by double clicking on it.  

• Click the Standard Filter icon from the main toolbar. A Filter window will 

appear. 

• Select Maths in the Field name box. 

• Select > operator in the Condition box. 

• Type 90 in the Value box. 

• Click on OK.  

� To remove the filter, click on the Remove Filter / Sort             icon. The original 

table, with all the records is displayed. 
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6. How can a database be queried in staroffice base? (or) What is query? Write the steps 

involved in generating a query? [Mar-07, June-10] 

Query: 

� Queries are user-constructed statements that set conditions for selecting and 

manipulating data in one or more tables and assembling the criteria-matching 

data into information. 

� SQL is a special query language for communicating with a database by 

describing data. 

� Queries are special views of the data in a table. Unlike sort, the output from a 

query does not affect the original table.  

To create a query: 

� To create a query in StarOffice Base, right click on Queries in the <Database> 

pane. 

� On the Tasks pane ‘Create Query in Design view’, ‘Use wizard to Create 

Query’, ‘Create Query in SQL view’ options appears. 

� Click on ‘Use wizard to Create Query’ option. The Query wizard dialog box 

appears on the screen. 

� From the Tables combo box, which contains the list of available tables, select the 

table on which you want to create the query. 

� To select the fields to be included in the query, click on the field in the Available 

fields Text area and then click on the > button.  

� To select all the fields at the same time, click on the >> button. 

� And click on the Next button. Sort Order window appears.  

Sort Order Window: 

� This window allows you to specify four fields on which the results should be 
sorted.  

� The radio buttons on the right allow you to specify if the sort should be in the 
ascending order or in the descending order. Click on the Next button.  

Search conditions Window: 

� This window is used to specify the fields and the conditions on which the query 
should be based.  

� If you want to display the records that satisfy any one of the search criterion then 
select ‘Match any of the following’ or select ‘Match all of the following’ to 
display records that satisfy all the search criterion.  

� Click on the Next button.  
Query wizard - Detail or Summary Window: 

� This window specifies whether to display all records of the query, or only the 
results of aggregate functions. Click on the Next button.  

Aliases window: 

� This window allows you to provide the alias names for the fields. Click on the 
Next button. 

Overview window: 

� This window allows you to specify a name for the query.        
� Selecting the Display Query radio button will execute the query immediately. 

And the Modify Query option will allow you to modify the query.                                    
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VOLUME – II                               C++ 

1.OBJECT ORIENTED CONCEPTS USING C++ 
I. Two mark questions:  

1. Define object. [Mar-07, June-08, Oct-09, Mar-13, June-13, Oct-13, June-12, Oct-16] (or) 

What is the significance of an object [June – 10, June-14, June-15, Mar-17] 

Significance of an object: 

� An object is a group of related functions and data that serves those functions. 

� An object is a kind of a self-sufficient “subprogram” with a specific functional area. 

� An object attempts to capture a real world object in a program. 

 

2. What is Encapsulation [Oct – 07, Mar – 08, Oct – 08, Mar – 10, Oct – 10, Oct – 11, Mar – 12, 

Oct-15, Mar-16, June-16] 

Encapsulation: 

� The mechanism by which the data and functions are bound together within an 

object definition is called as ENCAPSULATION. 

� The process of grouping data and its related functions into units called as objects 

paves way for encapsulation. 

 

3. Define Polymorphism [Mar – 09, Mar – 11, Oct – 12, Mar-14, Oct-14] 

Polymorphism: 

� The ability of an object to respond differently to different messages is called as 

polymorphism. 

4. What is meant by inheritance [June – 07] 

Inheritance: 

� Inheritance is a process of creating new classes called derived classes, from the 

existing or base classes.  

� The derived class inherits all the properties of the base class. 

� Inheritance increases the functionality of a derived class and also promotes 

reusability of code. 

5. List any four advantage of Object Oriented Programming. [June – 09, Mar – 15] 

Advantages of Object Oriented Programming 

� Class data type allows programs to organize as objects that contain both data and 

functions. 

� Data hiding or Abstraction of data provides security to data, as unrelated member 

functions. 

� Polymorphism reduces software complexity. 

� Inheritance allows a class to be derived from an existing class, thus promoting 

reusability of code, and also promote insertion of updated modules to meet the 

requirements of the dynamic world. 
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2.OVERVIEW OF C++ 

1. Define tokens. (or) Write the classification of tokens [June – 08, Mar – 12, Oct – 12, 

Mar-14, June-16, Mar-17] 

Tokens: 

� The basic types are collectively called as TOKENS.  

� A token is the smallest individual unit in a program. 

Classification of Tokens: 

1. Keywords  

2. Identifiers  

3. Constants  

4. Operators  

5. Punctuators   

 

2. What are keywords? Give an examples [Mar – 09, Mar – 13] 

Keywords: 

� Keywords have special meaning to the language compiler.  

� These are reserved words for special purpose.  

� These words cannot be used as normal identifiers. 

For example,         

auto, break, case, const, class 

 

3. Write a note on identifiers in C++ [Mar – 11] 

Identifiers: 

� Identifiers are also called as variables. Variables are memory boxes that hold 

values or constants.  

� A variable name must begin with an alphabet or underscore followed by 

alphabets or numbers.  

For example,        

 _test;     test;     sum12 are some valid identifiers. 

 

4. What is escape sequence? Give example [June – 12] 

Escape sequence: 

� Escape sequences are represented using characters prefixed with a backslash. 

� Certain special characters like tab, backspace, line feed, null, backslash are called 

as non-graphic character constants.  

� These characters are represented using escape sequences.  

For example, 

\a  - Bell 

\b  - Back space 

\n  - New line / line feed 
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5. Write a note on String literal [June – 09] 

String literal 

� String Literal is a sequence of characters surrounded by double quotes.  

� String literals are treated as array of characters.  

� Each string literal is by default added with a special character ‘\0’ which marks 

the 

end of a string.  

For example,     “testing” 

 

6. Define constants [June – 13] 

Constants 

� Constants are data items whose values cannot be changed. A constant is of 

numeric or non-numeric type.  

� Numeric constants consist of only numbers, either whole numbers or decimal 

numbers.  

� Integer and floating-point constant are the types of numeric constants.  

 

7. Which operators are specific to C++ [June – 08] 

The following operators are specific to C++. 

:: - Scope resolution operator 

.*  - Dereference operator  

->* - Dereference pointer to class member 

 

8. What is meant by association in C++ [June – 11] 

Association in C++: 

� Operators are executed in the order of precedence.  

� The operands and the operators are grouped in a specific logical way for 

evaluation. 

� This logical grouping is called as association. 

 

9. Explain conditional operator with example [Mar – 07, Oct – 07, June – 11, June – 12, 

Oct–12, Oct – 13, June-14, Mar-15, June-15, Oct-16] 

Conditional operator: 

� A ternary operator ( ?:) is also called as conditional operator.  

The general syntax is  

E1 ? E2 : E3 

� where E1,E2,E3 are operands. E1 should essentially be of scalar type, E2 and E3 

are values or statements.  

For example,  

max = (num1 > num2) ? num1 : num2;  

� The variable max will take the value of num1 if num1 is greater than num2, 

otherwise max will be assigned with the value of num2. 
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10. List out the relational operators associated with C++ [Mar – 08] 

Relational Operators: 

� Relational Operators are used to compare values.  

The list of relational operators are : 

= =  - equal to 

>  - greater than 

<  - lesser than 

>=  - greater than or equal to 

<=  - lesser than or equal to 

!=  - not equal to 

� A relational expression is constructed using any two operands connected by a 

relational operator.  

For example, 

10 > 20 

500.45 <= 1005 

 

11. Write a note on assignment operators [June – 07, June – 12] 

Assignment Operators: 

� = is the simple assignment operator.  

� It is used to assign the result of an expression (on the right hand side) to the 

variable (on the left hand side of the operator).  

� In addition to the simple assignment operator, there are 10 ‘shorthand’ 

assignment operators in C++ 

For example, 

A = 5  

A += 2 

 

12. List any four punctuators in C++ [Mar – 11, Oct – 12, Oct-14] 

Punctuators 

Punctuators are characters with a specific function.  

Punctuators Purpose 

;  - Terminates a C++ statement 

//  - Treats statements prefixed with this as comments 

/* */  - Blocks enclosed within these characters are treated as comment 

{ }  - Used to group a set of C++ statements. Coding for a function is also 

enclosed within these symbols 

[ ]  - Index value for an element in an array is indicated within these 

brackets 

‘ ’  - Is used to enclose a single character 

“ “  - Is used to enclose a set of characters 
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13. What is data types in C++? What are the different types [Oct – 11] 

Data Types 

� Data Types are the kind of data that variables hold in a programming 

language.  

� The ability to divide data into different types in C++ enables one to work with 

complex objects. 

� It can be broadly classified into the following three categories. 

User defined type 

Built-in type 

Derived type 

 

14. List out user defined data types [June – 07] 

User defined data types 

� User defined data type helps in improving readability of the program. 

1. Structure 

2. Union 

3. Class 

4. Enumeration 

 

15. Write about type def in C++ [Mar – 08, Oct – 08, Mar – 10, Mar – 13, oct-16] 

Type def in C++ 

� Users can define a variable that would represent an existing data type. 

� “Type definition” allow users to define such user defined data type identifier.  

The syntax : 

typedef data_type user_defined_data_type_identifier; 

For example: 

typedef int marks; 

typedef char grade; 

� The data type identifiers marks and grade are user defined identifiers for int and 

char respectively.  

 

16. Write a short note on enumerated data type [Oct – 07, Mar-15] 

Enumerated data type 

� Another user defined data type is they enumerated data type.  

� As the name suggests, enumerated data type helps users in creating a list of 

identifiers, also called as symbolic numeric constants of the type int. 

The syntax : 

enum data type identifier (value 1, value 2, … value n); 

Examples : 

enum working_days (Monday, Tuesday, Wednesday, Thursday, Friday); 

enum holidays (Sunday, Saturday); 
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17. What are the four storage specifiers in C++ [Oct – 07, June – 09] 

(or) Write a note on storage class in C++ [Oct – 10, Mar-15] 

Storage class: 

� Storage Class is another qualifier, that can be added to a variable declaration. The 

four storage specifiers are  

1. auto 

2. static  

3. extern  

4. register 

� static and register variables are automatically initialized to zero when they are 

declared.  

� Auto variables are not initialized with appropriate values based on their data type. 

Auto variables get undefined values known as garbage. 

 

18. Give any two uses of void data type [Mar – 07, June – 10, June – 11, Mar – 12,       

Mar-14, June-15] 

Uses of void data type: 

� Void type has two important purposes 

• To indicate the a function does not return a value 

• To declare a generic pointer 

 

19. What are the pointer variables [June – 10, June – 08, Oct – 11, Oct-14, Oct-15,       

Mar-16, June-16] 

pointer variables: 

� A pointer is a variable that holds a memory address.  

� Pointers provide the means through which the memory locations of a variable 

can be directly accessed.  

� Every byte in the computer’s memory has an address.  

For example, 

int *a;  

� When a program is compiled, some memory is allocated to the variables by the 

compiler. The amount of memory allocated to each variable depends on the data 

type of the variable. 

 

20. Write about the impact of modifiers in C++ [Mar – 07, Mar – 09, Mar – 10, Mar – 11, 

Mar – 13, Oct – 13, June-15, Oct-15, June-16, Oct-16, Mar-17] 

The impact of modifiers : 

� unsigned modifies the range of the integer values as the sign bit is also used to 

store data. 

� long increases the bytes for a particular data type, thus increasing the range of 

values. 
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21. How are the pointer variable declared [Oct – 08, Oct – 11] 

Declaring pointer variables 

� A pointer is a variable that holds a memory address.  

int * iptr; 

Name of the pointer variable 

Instructs the compiler that the variable is pointer ( it will hold an 

address) 

Indicates that the pointer will point to an int data type 

� The declaration statement int *ptr may be read as ptr is a pointer variable of the 

type int.  

22. Write a note on size of operator [June – 10] 

size of operator: 

� sizeof is an operator . It returns the size (memory requirement) in terms of bytes, 

of the given expression or data type. 

For example, 

 int i = 10;  

float f = 5; 

 cout<<sizeof(i * f); 

 (The result is 4, because sizeof takes the highest byte) 

 

23. Determine the order of evaluation of the Expression   (b x b) – 4 x a * c [Oct – 08] 

Solution: 

   ( b      x      b)      -      4       x      a       x       c 

 

 

             x               x  

 

                 x 

 

 

                    - 

       

 

24. Evaluate the following C++ expressions assume a = 5, b = 3, d = 1.5, C is Int and F is 

float a) F = a + b / a  b) C = d * a + b     [Mar – 09] 

Solution: 

a) F = 5 + 3 / 5 

   = 5 + 0 

 F = 5 

b) C = 1.5 * 5 + 3 

    = 7.5 + 3 

    = 10 

www.Padasalai.Net                                             www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



J.P.MURUGAN, M.Sc.,B.Ed.,  CELL:9488832229            Page 66 

 

25. Find the output x = 5, F = 6, C = x++  +  ++F [Mar-10] 

Output: 

x = 5, F = 6,       

C = x++ + ++F 

    = 5++ + ++6 

    = 5 + 7 

 C = 12 

 

26. Find the value of C  x = 10, F = 20, C = x++ + ++F [Oct – 09, Mar – 10, Oct – 10, Oct-15] 

Output: 

x = 10, F = 20,       

C = x++ + ++F 

    = 10++ + ++20 

    = 10 + 21 

 C = 31 

 

27. Write C++ equivalent expression using conditional operator, [Oct – 11, Mar – 12] 

(i)f = 0.5  if  x = 30 otherwise f = 5 (ii) fn = 0.9   if   x >= 60  otherwise 0.7  

Solution: 

i)    f = (x = = 30) ? 0.5 : 5 

ii)   fn = (x >= 60) ? 0.9 : 0.7 

 

28. What are the types of operators based on the operand requirements? 

Types of operators based on the operand requirements: 

� Based on operand requirements, operators are also classified as unary, binary and 

ternary operators. 

For example : 

Unary operators require one operand 

Binary operator requires two operands 

Ternary operator requires three operands. 

 

29. What is implicit conversion? Give example. [June-14] 

Implicit conversions:  

� refers to data type changes brought about in expressions by the compiler.  

For example, 

float f = 7.6; 

int x = f; 

� The value stored in the variable x is 7, as float is converted to int. The compiler 

does this conversion automatically. 
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30. If a = 5, b = 6, c = 7, What is the value of the expression a+=b*c? [June-14] 

Solution: 

a+=b*c 

a = a + b * c 

a = 5 + 6 * 7 

a = 5 + 42 

a = 47 

 

31. Explain const qualifier. [Oct-14] 

const qualifier: 

� The const qualifier specifies that the value of a variable will not change during 

the run time of a program.  

� Any attempt to alter the value of a variable defined with this qualifier will throw 

an error message by the compiler.  

� The const qualifier is used like any other modifier where the variable is prefixed 

with the keyword const followed by data type. 

For example: 

const float pi = 3.14; 

 

32. What is modifier? Give an example. [Mar-14] 

Modifier: 

� The modifier alters the base data type to yield new data type. 

� The base data type should be prefixed with the modifiers at the time of declaring 

a variable.  

For example: 

unsigned int a; 

long int b; 

signed char c; 

 

33. What is integer constant? 

Integer Constant: 

� Integer Constant must have at least one digit and must not contain any fractional 

part. May be prefixed with a + or – sign 

� A sequence of digits starting with 0 (zero) is treated as Octal constant  

Ex:      010 = 8        ( [8] 10 = [10] 8 ) 

� A sequence of digits starting with 0x is treated as hexadecimal integer.  

Ex:     0xF = 15       ( [15] 10 = [F] 16 ) 
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34. What is floating point constant? 

Floating Point Constant: 

� Floating Point Constant is a signed real number. It includes an integer portion, a 

decimal point, a fractional portion and an exponent. 

� While representing a floating point constant the integer portion or the decimal 

portion can be omitted but never both.  

For example,   

58.64 is a valid floating point (Real) constant.  

� It can be represented in exponent form as follows : 

• 5.864E1 => 5.864 x 101 => 58.64 

• 5864E-2 => 5864 x 10–2 => 58.64 

� The letter E or e is used to represent the floating-point constant exponent form. 

 

35. What is character constant? 

Character constant: 

� Character constant is a constant that contains a single character enclosed within 
single quotes.  

� It can be any character as defined in the character set of C++ language. Certain 

special characters like tab, backspace, line feed, null, backslash are called as non-

graphic character constants.  

� These characters are represented using escape sequences. Escape sequences are 

represented using characters prefixed with a backslash. 

For example, 

 ‘\a’, ‘\n’ 
 

36. What is meant operators? Give example. 

Operators: 

� Operator specifies an operation to be performed that yields a value. An operand is 

an entity on which an operator acts. 

For example : 

RESULT = NUM1 + NUM2 

� NUM1 and NUM2 are operands. + is the additional operator, that performs the 
addition of the numbers.  
 

37. List the logical operators are used in C++? 
Logical Operators (Boolean Operators) 

� Logical operators combines the results of one or more conditions.  

The various logical operators are  

&& -  (AND)  

||  - (OR)  

! - (NOT) 

For example, 

 ((a >= b) && (c == d) 
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38. List the arithmetic operators are used in C++? 

Arithmetic Operators 

� Arithmetic Operators are used to perform mathematical operations.  

The list of arithmetic operators are : 

+ - Addition operator 

- - Subtraction operator 

*  - multiplication operator 

/  - division operator 

%  - modulus operator - gives the remainder of an integer division 

+= , -=, *= , /= , %= 

� Arithmetic expressions are formed using arithmetic operators, numerical 

constants/variables, function call connected by arithmetic operators. 

For example,  

a = 10 - 5; 

a %= 3; 

 

39. Write a note on built-in data types? 

Built in Data Types: 

� Built in Data Types are also called as Fundamental or Basic data types. They are 

predefined in the compiler.  

� Integral, Float and Void are the three fundamental data types. 

� Integral type is further divided into int and char. Floating type is further divided 

into float and double.  

 

40. Write a short note on derived data type? 
Derived Data Type: 

� These are built from the basic integer and floating type (built in type) or user 
defined data types.  

For example,  

int num_array[5] = {1,2,3,4,5}; 

� num_array stores 5 values. Each element is accessed using the positional value of 

the element in the array.  

� The position numbering commences from zero.  

 

41. What is variable in C++? 

Variables: 

� Variables are user defined named entities of memory locations that can store 

data. 

� The name assigned to a data field that can assume any of a given set of values is 

defined as the variable.  

For example, 

  int num;  

num = 5  
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� Variable names may contain letters, numbers and the underscore character (_). 

Names must begin with a letter or underscore. 

 

42. How the variables are declared? (or) Write the syntax for variable declaration? 

Declaration of Variables 

� Variables are allocated memory to store data. Compiler allocates memory, based 

on the data type of the variable.  

� Hence variables must be declared before they are used. 

Syntax : 

 

  Data type              Space               Identifier               ; 

 

 

                                   ,  

 Example :  

int a; 

float f1, f2; 

char name[10], choice; 

 

43. What is type cast? Give an example. 

Type cast: 

� Type cast refers to the process of changing the data type of the value stored in a 

variable. .  

� Type cast is achieved by prefixing the variable or value with the required data 

type.  

Syntax:  

(data type) <varaible/value>  

(or)  

data type (variable/constant) .  

� Type cast is restricted only to fundamental or standard data types.  

For example, 

x = 8 % (int) 7.7      - the float constant 7.7 is converted to integer constant by 

type casting it. 

 

44. What are the two reasons for data is grouped into different categories? 

Data is grouped into different categories for the following two reasons: 

� The compiler may use the proper internal representation for each data type 

� The programmer designing the programs may use appropriate operators for each 

data type. 
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3.BASIC STATEMENTS 
1. What is the use of insertion operator (or) put to operator in C++? [June – 12] 

(or) What is the purpose of cout object in C++? 

Insertion operator (or) put to operator 

� cout is a predefined object of standard output stream.  

� The standard output stream normally flows to the screen display – although it can 

be redirected to several other output devices.  

� The declarations for the object cout are available in a header file called as 

ostream.h 

� The operator << is called the insertion operator or put to operator.  It directs the 

contents of the variable to its right to the object to its left.  

For example, 

int a = 85; 

cout << a; 

 

2. What are the various section of a C++ program [June – 09, Mar-15, Mar-17] 

The various section of a C++ program 

� A C++ program has primarily three sections viz., 

• Include files 

• Declaration of variables , data type , user defined functions. 

• main() function 

 

3. Write about in assignment statement in C++ [Mar – 08] 

Assignment Statements 

� An assignment statement, assigns value on the right hand side of an expression to 

the variable on the left hand side of the assignment operator.  

� ‘=’ is the assignment operator .  

For example  

a = 5; 

b= x+y; 

 

4. What are the control statements (or) What are the two main categories of control 

structure [Oct – 07, Oct – 11, Oct – 12] 

Control statements: 

� Statements in a program need not necessarily be executed in a sequential order.  

� Some segments in a program are executed based on a condition.  

� Program statements that cause a jump of control from one part of a program to 

another are called Control Structures. 

The two major categories of control structures are  

i) Decision making statements (Selection statements) and  

ii) Looping statements.  
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5. Write the syntax of nested if statement [Oct – 08] (or) write a note on nested if 

statement in C++. [Oct – 16] 

Nested if statement: 

� The statement sequence of if or else may contain another if statement ie., the if .. 

else statements can be nested within one another. 

Syntax of nested if statement: 

 if (expression 1) 

 if (expression 2) 

 { 

 action 1; 

 } 

 else 

 { 

 action 2; 

 } 

 else 

 { 

 action 3; 

 } 

� In an nested if .. else statement, “Each else matches with the nearest 

unmatched preceding if” 

 

6. Write the syntax of  i) if….else  ii) do…while    [June-15] 

� if..else statement is a two way decision making statement. 

Syntax of if…..else statement: 

 if( condition / expression) 

 { 

 action block1; 

 } 

 else  

 { 

 action block 2; 

 } 

� do-while loop is also called as exit check loop. 

Syntax of do…..while statement: 

 do 

 { 

 action block; 

 }while<(condition)>; 
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7. Write the syntax of switch case statement [Oct – 09, Mar-16] 

switch Statement :  

� This is a multiple branching statement where, based on a condition, the control is 

transferred to one of the many possible points. 

Syntax of switch case statement: 

 switch( expression) 

 { 

 case 1: action block; 

    break;  

 case 2: action block; 

    break;  

 case 3: action block; 

    break;  

 default: action block; 

 } 

 

8. What is loop? Write their types [Mar – 13, June-16] 

Loops: 

� Loops execute a set of instructions repeatedly for a certain number of times. 

� A looping block therefore consists of two segments viz., the body of the loop and 

the control statement. 

Types of loop: 

There are three kinds of loops in C++,  

1. the for loop,  

2. the while loop and 

3. the do .. while loop. 

 

9. Write a brief note on Break and continue statement [Mar – 11, Mar – 12] 

Break statement  

� Every action block should be terminated with a break statement. 

� Otherwise all action blocks are executed sequentially from the point where the 

control has been transferred based on the condition. 

� A loop’s execution is terminated when the test condition evaluates to false. Under 

certain situations one desires to terminate the loop, irrespective of the test 

expression. 

Continue statement 

� The continue statement forces the next iteration of the loop to take place, 

skipping any code following the continue statement in the loop body. 
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10. What is the purpose of continue statement [June – 07, June-14] 

The purpose of continue statement 

� The continue statement forces the next iteration of the loop to take place, 

skipping any code following the continue statement in the loop body. 

 

11. Write the rules for the formation of nested loops [June – 08, Mar – 09, June-10,      

June-13, Oct – 13] 

The rules for the formation of nested loops are : 

� An outer loop and inner loop cannot have the same control variable, as it will 

lead to logical errors 

� The inner loop must be completely nested inside the body of the outer loop. 

 

12. What is if statement? write the syntax? [Mar-14]  (or) How the if statement is 

implemented? 

if statement :  

� if statement is the simplest of all the decision statements. It is implemented in 

two forms 

i) Simple if statement 

ii) if .. else statement 

 Syntax of simple if statement:   Syntax of if…..else  statement: 

 if( condition / expression)   if( condition / expression) 

 {       { 

 action block1;     action block1; 

 }       } 

        else  

        { 

        action block 2; 

        } 

 

13. What is the use of break statement? [Oct-14, Mar-17] 

Break statement  

� Every action block should be terminated with a break statement. 

� Otherwise all action blocks are executed sequentially from the point where the 

control has been transferred based on the condition. 

� A loop’s execution is terminated when the test condition evaluates to false. Under 

certain situations one desires to terminate the loop, irrespective of the test 

expression. 
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14. Write the syntax of for loop. [Oct-15] 

for loop: 

� for (; ; ) .. loop : is an entry controlled loop and is used when an action is to be 

repeated for a predetermined number of times.  

The syntax is: 

for(intial value ; test-condition ; increment) 

{ 

    action block; 

} 

 

15. What is the use of cin object in C++? (or) What is the use of extraction or get from 

operator?  

Use of extraction or get from operator: 

� Data is read from the keyboard during runtime by using the object cin.  

� cin is a predefined object that corresponds to a standard input stream. 

� The declarations for the object cin are available in a header file called as 

istream.h 

� The >> is the extraction or get from operator. It takes the value from the stream 

object to its left and places it in the variable to its right.  

For example,  

float a; 

cin >> a; 

 

16. What is declaration statement in C++? (or) What is the use of declaration statement? 

Declaration Statements: 

� Variables used in the declaration statements need to be declared and defined 

before they are used in a program. 

� Declaration of a variable introduces a variable’s name and its associated data 

type.  

For example, 

int num; 

 

17. What is selection statement (or) What are the decision making statements in C++? 

Selection statement (or) Decision making statements 

� In a program a decision causes a one time jump to a different part of a program.  

� Decisions in C++ are made in several ways, most importantly with if .. else … 

statement which chooses between two alternatives.  

� Another decision statement, switch creates branches for multiple alternatives 

sections of code, depending on the value of a single variable. 
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4.FUNCTIONS 

1. Write the advantages of using functions [June – 07, Oct – 07, Oct – 09, Mar – 10,        

June–12, June – 13, June-14, June-15, Oct-15, June-16] 

Advantages of using functions: 

� Reduce the size of the program. 

� Induce reusability of code. 

� A function can be shared by other programs by compiling it separately and 

loading them together. 

 

2. What is the main purpose of function prototype [Mar – 09, Mar-14] 

The main purpose of function prototype: 

� The main purpose of function prototype is to help the compiler to check the data 

requirement of the function.  

� With function prototyping, a template is always used when declaring and 

defining a function.  

� Functions should be declared before they are used in a program. Declaration of a 

function is made through a function prototype. 

 

3. Write the general syntax & examples for function prototype [Mar – 11, June – 12] 

Function Prototyping: 

� Functions should be declared before they are used in a program. 

� Declaration of a function is made through a function prototype. 

The general syntax of a function prototype 

<type > <function identifier > <arguments); 

For example : 

void fun (char); 

int max (int, int); 

int max (int a, int b); 

 

4. What are the rules for actual parameter [June – 13, Oct-14] 

Rules for actual parameters: 

� The actual parameters can be passed in the form of constants or variables or 

expressions to the formal parameters which are of value type. 

For example, 

int add (int n1, int n2);  

x = add (5, 10); 

� The actual parameters can be passed only as variables to formal parameters of 

reference type. 

For example, 

int add (int & n1, int & n2); 

x = add (a1, b1) ; where a1 and b1 are variables 
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5. Differentiate between call by value & call by reference [June – 09, Oct – 10, Mar – 12, 

Mar-16] 

call by value & call by reference: 

Call by value Call by reference 

� In this method, the called function 
creates new variables to store the 
value of the arguments passed to it.  

� In this method, the called function 
arguments - formal parameters 
become alias to the actual parameters 
in the calling function.  

� This method copies the values of 
actual parameters into the formal 
parameters, thus the function 
creates its own copy of arguments 
and then uses them. 

� This means that when the function is 
working with its own arguments, it is 
actually working on the original data. 

� In call by value method, any 
change made in the formal 
parameter is not reflected back to 
the actual parameter. 

� In call by reference method, any 
change made in the formal parameter 
is reflected back to the actual 
parameter. 

 

6. What are inline functions? [Mar – 07, Mar – 08, June – 08, Oct – 08, June – 10,      

Mar – 13, Mar-15] 

Inline functions: 

� An inline function looks like a normal function in the source file but inserts the 

function’s code directly into the calling program. 

� Inline function execute faster but require more memory space. 

� To make a function inline, one has to insert the keyword inline in the function 

header. 

  

7. List the type of scope rules of variables in C++ [June – 11, Oct-16] 

Type of scope rules of variables: 

� Scope refers to the accessibility of a variable. There are four types of scopes in 

C++. They are, 

1. Local scope               

2. Function scope 

3. File scope                  

4. Class scope 

 

8. Write a note on file scope in C++. [Oct – 11] 

File scope: 

� A variable declared above all blocks and functions has the scope of a file.  

� The scope of a file scope variable is the entire program.  

� The life time of a file scope variable is the life time of a program. 

 

www.Padasalai.Net                                             www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



J.P.MURUGAN, M.Sc.,B.Ed.,  CELL:9488832229            Page 78 

 

9. What is meant by return statement? (or)  What is the use of return statement? [Mar-17] 

Use of return statement: 

� return statement marks the end of the function. 

� And also transfers control to the statement after call statement. 

 

10. What are functions? Give an example. 

Functions: 

� Functions are the building blocks of C++ programs. Functions are also the 

executable segments in a program.  

� The starting point for the execution of a program is main( ). 

For example, 

int sum (int x, int y) 

{  

return x+y; 

} 

void main() 

{ 

cout<<sum(10, 20); 

} 

 

11. What is calling a function?  (or) Write the working of a function? 

Calling a function: 

� A function can be called or invoked from another function by using its name.  

� The function name may include a set of actual parameters, enclosed in 

parentheses separated by commas. 

Working of a function : 

int add(int, int) 

…. 

return a+b; 

void main()                            Indicates transfer of control 

{ 

…... 

sum = add(x1,x2); 

cout << sum; 

} 

 

 

12. Write the advantages of inline functions? 

Advantages of inline functions 

� Reusability of code leading to saving of memory space and 

� Reduction in code size. 
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13. How the parameters are passing to functions?    (or) 

In C++, how many ways arguments can be invoked to functions?  

Parameter Passing in Functions 

� The call statement communicates with the function through arguments or 

parameters. 

� Parameters are the channels through which data flows from the call statement to 

the function and vice versa. 

� In C++, functions that have arguments can be invoked by 

1. Call by value 

2. Call by reference 

 

14. What is call by value method in C++?  

Call by value: 

� In this method, the called function creates new variables to store the value of the 

arguments passed to it. 

� This method copies the values of actual parameters into the formal parameters, 

thus the function creates its own copy of arguments and then uses them. 

� “In call by value method, any change made in the formal parameter is not 

reflected back to the actual parameter.” 

 

15. What is call by reference method in C++?  

Call by reference: 

� In this method, the called function arguments - formal parameters become alias to 

the actual parameters in the calling function. 

� This means that when the function is working with its own arguments, it is 

actually working on the original data. 

� “In call by reference method, any change made in the formal parameter is 

reflected back to the actual parameter.” 

 

16. Write a note on local scope in C++.  

Local scope: 

� A local variable is defined within a block. 

� The scope of a local variable is the block in which it is defined. 

� A local variable cannot be accessed from outside the block of its declaration. 

� Local variables are not known outside their own code block. A block of code 

begins and ends with curly braces { }. 

� Local variables exist only while the block of code in which they are declared is 

executing. 

� A local variable is created upon entry into its block and destroyed upon exit. 
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17. Write a note on function scope in C++.  

Function scope 

� The scope of variables declared within a function is extended to the function 

block, and all sub-blocks therein. 

� The life time of a function scope variable, is the life time of the function block.  

� The scope of formal parameters is function scope. 

 

18. Write a note on class scope in C++. 

Class scope: 

� The data variables declared within the class has the scope of a class. 

� Their scope will be decided by the access specifier private, protected, public. 

� The life time of a class scope variable is the life time of the class.  

 

19. What is the use of scope operator? 

Scope Operator: 

� The scope operator reveals the hidden scope of a variable. 

� :: is called as scope resolution operator.  

� It is used to refer variables declared at file level.  

� This is helpful only under situations where the local and file scope variables have 

the same name. 

 

20. What are the information the prototype provides to the compiler? 

� The prototype provides the following information to the compiler. 

1. Number and type of arguments. 

2. The type of return values. 
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5.STRUCTURED DATA TYPE ARRAYS 

1. What is an Array? Write it’s different types [June – 07, June – 11, June – 12,               

Oct – 12, Mar-14, Oct-14, Mar-15, Mar-16, Mar-17] 

Array: 

� An array in C++ is a derived data type that can hold several values of the same type. 

� An array is a collection of variables of the same type that are referenced by a 

common name. 

Types of array: 

Arrays are of two types, 

i) One dimensional array 

ii) Multi dimensional array 

 

2. What are the two types of array? Define them [Oct – 08, June-15] 

Array: 

� An array is a collection of variables of the same type that are referenced by a 

common name. 

Types of array: 

Arrays are of two types, 

i)  One dimensional:  - comprising of finite homogenous elements 

ii)  Multi dimensional:  - comprising of elements, each of which is itself a  

     one- dimensional array 

 

3. Find the errors: a) int a[5.5];  b) float num [A];  [Oct – 09, June-16] 

Solution: 

a) Dimension of an array should be only an integer.  

b) Dimension of an array should be explicitly mentioned. Here, the identifier A does 

not have a value.   

 

4. Write the syntax for single dimension Array with examples [Mar – 13, June – 13] 

Single Dimension Array: 

� These are suitable ways for processing of lists of items for identical types. 

Syntax: 

data type          space           array_identifier              [            size            ]    ; 

For example,  

int num[5]; 

� The size of the array should always be positive. The array subscripts always 

commences from zero. 
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5. Write a note on write() function with syntax. [June – 09, Mar – 11, Mar-14, June-14, 

Oct-14, June-16] 

write() function: 

� write( ) is a member function of standard output stream, i.e., ostream. All member 

functions of a class, should be accessed through an object /instance of class. 

� The two parameters required for write () function are identifier string characters, and 

no. of characters to be displayed. 

� write( ) method is used to display ‘n’ number of character from a string on the screen. 

Syntax: 

 cout.write(identifier string characters, no.of characters); 

For example,  

cout.write(name, 10); 

 

6. What is the purpose of strlen() function [June – 08, Mar – 12, Oct-16] 

Purpose of strlen( ) function: 

� The strlen( ) function returns the number of characters stored in the array. 

� The strlen( ) function is declared under the header file string.h 

Syntax: 

  var = strlen(char*);  

For example, 

  int a; 

char name [] = “computer”; 

  a = strlen(name); 

  cout<<a; 

� From the above snippet, the strlen( ) function returns the value is 8. 

 

7. What is the purpose of strcpy() [Mar – 09, Oct – 13] 

Purpose of strcpy( ) function: 

� The strcpy( ) function is used to copy the source string to target string. 

� The strcpy( ) function is declared under the header file string.h 

Syntax: 

   strcpy(char*, char*); 
(or) 

strcpy(string1, string2) 
  Where,  

  string1 – is the target string. 
  string2 – is the source string. 
For example, 

  char string1[100], string2[100] = “computer”; 

  strcpy(string1, string2); 

  cout<<string1; 

� From the above snippet, the content of string2 is assigned (copy) to the 

content of string2.  
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8. What is the use of strcmp() function [Oct – 07, June – 07, Oct – 07, June – 09, Mar – 10, 

June – 13, Mar-17]  

Purpose of strcmp( ) function: 

� The strcmp( ) function is used to compare two given strings to find whether the 

strings are same or different. 

� The given two strings are compared character by character until end of the each 

string. 

� The strcmp( ) function is declared under the header file string.h 

Syntax: 

   strcmp(char*, char*); 

(or) 

strcmp(string1, string2) 

  Where,  

  string1 and string2 are the character array. 

For example, 

i) strcmp(“Abc”, “Abc”); 

It returns a value 0 (zero). 

ii) strcmp(“Abc”, “abc”); 

It returns a value less than 0 (zero) <0. 

iii) strcmp(“abc”, “Abc”); 

It returns a value greater than 0 (zero) >0.  

 

9. How will you declare 2D array [June – 08, Mar – 09, Mar – 10, Oct – 12]        (or) 

write a note on 2-D array? Give example. [June-14] 

Two-Dimensional Array: 

� A two-dimensional array is an array in which each element is itself an array. 

A 2-D array is declared as: 

Type array-id [Rows] [Columns]; 

For example, 

int makrs [3] [4]; 

� The number of elements in a 2-dimensional array is determined by multiplying 

the number of rows with number of columns.  

� The subscripts always commence from zero.  

 

10. What are the different ways to indicate the dimensions (row/column) of an array [Oct – 10] 

Indicate the dimensions (row/column) of an array 

1. using integer constants 

2. using const identifier of integer or ordinal 

3. using char constants 

4. using enum identifiers 
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11. What is meant by array of Strings [Mar – 07, Oct – 08, June – 10, June – 11,             

Mar – 13, Mar-15] 

Array of Strings: 

� An array of strings is a two-dimensional character array.  

� The size of first index (rows) determines the number of strings and the size of 

second index (column) determines maximum length of each string. 

For example, 

char day-names [7] [10] = {“Sunday”, 
“Monday”, 
“Tuesday”, 
“Wednesday”, 
“Thursday”, 
“Friday”, 
“Saturday”}; 

� Attaching the null character (\0) to each string literal is optional. Even if we omit 

it, the C++ compiler will automatically attach it. 

 

12. Define matrix. [Oct-16] 

Matrix: 

� A matrix is a set of mn numbers arranged in the form of a rectangular array of m 

rows and n columns.  

� Matrices can be represented through 2-D arrays. 

For example,      int a[10];     int b[3][3]; 

 

13. Explain the memory representation of 2 – D array [Mar – 07, June – 10, Oct – 11, 

June-15] 

Memory representation of 2-D arrays: 

� A 2-D array is stored in sequential memory blocks.  

The elements are stored either 

1. row-wise manner (this method is called as row-major order) 

2. column-wise manner (this method is called as column-major order) 

For example: 

int sales [2] [4]; will be stored as follows: 

In row-major order 

 

 

 

 

 

                                                                       

                                                                

                                                                        

                                                                  

(0, 0)  

(0, 1)  

(0, 2)                     

 (0, 3)  

(1, 0)  

(1, 1)  

(1, 2)  

(1, 3)  

1st row 

2nd row 
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In column-major order 

 
 
 
 

 
 
 
 

 

 

 

14. Find the number of elements and memory size of 2D array. 

(i)  int product[2][4];  [Mar – 13, June – 13] 

Solution: 

i) int product[2][4] 

number of elements =  Rows x Columns 

   =  2 x 4 

0!number of elements  =  8 

ii) size of the array = Number of elements * memory for particular data type 

    = 2 * 4 * 2 

 0 size of the array = 16 bytes 

 

15. If int x[ ][2] = {0,1,2,3,4,5}, then what is the value of x[1][1]? [Oct – 12] 

Solution: 

The value of x[1][1] is = 3 

 

16. What is the size of the array?    float num[4][6]. [Oct-15] 

Solution: 

i) float num[4][6] 

size of the array = Number of elements * memory for particular data type 

    = 4 * 6 * 4 

 0 size of the array = 96 bytes 

 

17. What will be the output of the following program? [Mar-16] 

#include<iostream.h> 

void main() 

{ 

char ch[] = {“NULL\0”}; 

cout<<ch; 

} 

Output: 

 NULL 

(0, 0)  

(1, 0)  

(0, 1)                     

 (1, 1)  

(0, 2)  

(1, 2)  

(0, 3)  

(1, 3)  

1st column 

2nd column 

3rd column 

4th column 
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18. Write the syntax of gets( ) function.   

gets( ) function: 

� To treat spaces as part of string literal, then one has to use gets ( ) function 

defined in stdio.h 

Syntax for gets ( ) 

gets (char array identifier)        or        gets (char *) 

 For example,  

  gets(name); 

 

19. Write the syntax of getline( ) function.   

getline( ) function: 

� To treat spaces as part of string literal, then one has to use getline ( ) - a member 

function of standard input stream., istream.h 

Syntax for getline  

cin.getline (char*, no.of characters, delimiter); 

For example,  

  cin.getline (pincode, 7, ’#’); 

 

20. What are strings? Give example. (or) What is meant by array of characters? 

Strings: 

� Strings are otherwise called as literals, which are treated as single dimensional 

array of characters.  

� The declaration of strings is same as numeric array.  

For example, 

char name [10]; 

char vowels [ ] = {‘a’, ‘e’, ‘i’, ‘o’, ‘u’}; 

char rainbow [ ] = “VIBGYOR”;  

� A character array should be terminated with a ‘\0’ (NULL) character. 

 

21. What are the two methods to display the content of string? 

� There are two methods to display the content of string. 

1. cout                          - Eg:    cout<<name; 

2. cout.write()              - Eg:    cout.write(name, i); 
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CLASSES AND OBJECTS 

1. What is a class? Give examples [Oct – 08, Oct – 12, Mar – 13, Oct-16] 

Class: 

� The most important feature of C++ is the “Class”. A class is a new way of 

creating and implementing a user defined data type.  

� Classes provide a method for packing together data of different types.  

� “A class is a way to bind the data and its associated functions together.” 

For example, 

class student 

{ 

int a,b,c; 

void sum(); 

}; 

 

2. Define class and write about specification of class [Oct – 13] (or) What are the two part 

of class specification [Oct – 07, Mar – 10, June – 12, June-15, Oct-15, Mar-17] 

Class: 

� The most important feature of C++ is the “Class”.  

�  “A class is a way to bind the data and its associated functions together.” 

Class specification: 

A class specification has two parts: 
1. Class declaration 
2. Class Function Definitions 

 
3. Write the general form of class declaration [Oct – 07, June – 11, Oct – 11, Mar-15, Mar-17] 

The general form of class declaration is 

class class-name 
{ 
private: 
variable declaration 
function declaration 
protected: 
variable declaration 
function declaration  
public: 
variable declaration 
function declaration  
}; 
 

4. Define encapsulation [June – 09] 

Encapsulation: 

� The binding of data and functions together into a single entity is referred to as 

encapsulation. 
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5. What is mean by data hiding [June – 07, Oct – 10, Mar – 11, June – 13] 

Data hiding: 

� The members and functions declared under private are not accessible by 

members outside the class, this is referred to as data hiding.  

� Data hiding is the key feature of object oriented programming ( OOPS) 

 

6. What is data abstraction [June – 08, Mar – 09, Oct – 09, June – 10, June – 11, Oct – 

13, Oct-14, Mar-15] 

Data abstraction: 

� Instruments allowing only selected access of components to objects and to 

members of other classes is called as Data Abstraction.  

� Or rather Data abstraction is achieved through data hiding. 

 

7. Explain the access specifiers of a class [Mar – 09] (or) 

How many access specifier are there in a class body? What are they [Oct – 12] 

Access specifiers: 

� The class body has three access specifiers ( visibility labels) viz., private , public 

and protected. 

private: 

� Specifying private visibility label is optional. The members that have been 

declared as private, can be accessed only from within the class. 

protected: 

� The members that have been declared as protected can be accessed from within 

the class, and the members of the inherited classes. 

public: 

� The members that have been declared as public can be accessed from outside the 

class also. 

 

8. What does a class comprise? [Oct – 11]    (or) Define data member and member 

functions. [June-15, Mar-16, Oct-16]    (or) Write a note on class members in C++. 

[Mar-14] 

A class comprise: 

� Class comprises of members. Members are further classified as Data Members 

and Member functions.  

Data members 

� Data members are the data variables that represent the features or properties of a 

class.  

� Data members are called as attributes.  

Member functions 

� Member functions are the functions that perform specific tasks in a class. 

� Member functions are called as methods. 
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9. Explain the two methods of creating objects in C++ [Oct – 08]   (or) 

What are the different ways of a creating objects [June – 09] 

Creating Objects: 

� In C++ the class variables are known as objects. There are two methods for 

creating objects in C++. 

� The declaration of an object is similar to that of a variable of any basic type.  

� Objects can also be created by placing their names immediately after the closing 

brace of the class declaration. 

 

For example, 

Method-1      Method-2 

 class student     class student 

{      { 

private:     private: 

…………….    ……………. 

protected:     protected: 

…………….    ……………. 

public:     public: 

…………….    ……………. 

}stud;      }; 

// stud is an object of    void main() 

   class student    { 

student s1, s1; 

} 

// The variable s1, s2 are objects or  

instance of the class student. 

 

 

10. How are the class member accessed [June – 08]    (or)    What is the use of dot 

operator? Give example and explain. [Mar-14, June-16] 

Accessing Class Members: 

� The members of a class are accessed using the dot operator. 

For example, 

 stud . execute() 

   

     member function 

     dot operator 

     object name 

� The objects declared outside the class cannot access members or functions 

defined under private or protected. 

� The member functions declared under public can be accessed by the objects of 

that class. 
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11. Write the characteristics of member functions [Mar – 07, June – 07]    (or) 

List any four characteristics of member function used in program development [June – 

10, Mar-16] 

Characteristics of member functions: 

� Several different classes can use the same function name. The ‘membership’ 

label will resolve their scope. 

� Member functions can access the private data of a class. A nonmember function 
cannot do so. 

� A member function can call another member function directly, without using the 
dot operator.  

� The member functions can receive arguments of a valid C++ data type. Objects 
can also be passed as arguments 

� The return type of a member function can be of object data type 

� Member functions can be of static type 

 

12. What is meant by nesting of member function [June – 13] 

Nesting of member function: 

� A member function can call another member function directly, without using 

the dot operator. This is called as nesting of member functions. 

 

13. Write a short note on memory allocation of objects [Mar – 08, Mar – 10] 

Memory allocation of objects: 

� The member functions are created and placed in the memory space only when 

they are defined as a part of the class specification. 

� No separate space is allocated for member functions when the objects are 
created.  

� Memory space required for the member variables are only allocated separately 
for each object.  

� Separate memory allocations for the objects are essential because the member 
variables will hold different data values for different objects 

� Memory space is allocated to an object defends on their data types and 

variables. 

 

14. Write a note on static data members [Oct – 10, Mar – 11, Mar – 13, Mar – 12, June-

14, Oct-14, Oct-15, June-16] 

Static data members: 

� A data member of a class can be qualified as static. The static member variable, 

1. Is initialized to zero, only when the first object of its class is created. No other 

initialization is permitted 

2. Only one copy of the member variable is created and is shared by all the other 
objects of its class type 

3. Its scope or visibility is within the class but its lifetime is the lifetime of the 
program. 

www.Padasalai.Net                                             www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



J.P.MURUGAN, M.Sc.,B.Ed.,  CELL:9488832229            Page 91 

 

15. Write a note on array of objects [Mar – 07, Mar – 08, Oct – 09] 

Array of objects: 

class product 

{       code  

int code,quantity;     quantity p[0] 

float price;      price      

public :       

void assign_Data();    code 

void display();     quantity p[1]     

} p[3];      price 

void main() 

{       code 

p[0].assign_Data();    quantity p[2] 

p[0].display();     price 

} 
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7.POLYMORPHISM 

1. What is function overloading [Mar – 13, Oct – 08, June – 13, June-15] 

Function overloading: 

� The ability of the function to process the message or data in more than one form 

is called as function overloading.  

� Function overloading is one of the facets of C++ that supports object oriented 

programming. 

For example, 

float area ( float radius); 

float area ( float half, float base, float height ); 

float area ( float length , float breadth); 

2. How are the functions are invoked in function overloading [Mar – 07, June – 07,             

Oct – 09, Mar – 10, Mar – 11, June – 11, Mar – 12, Mar-14, Mar-17] 

Functions are invoked in function overloading: 

� The compiler adopts BEST MATCH strategy. As per this strategy, the compiler 
will, 

� The compiler will look for the exact match of a function prototype with that of a 

function call statement. 

� In case an exact match is not available, it looks for the next nearest match. That 

is, the compiler will promote integral data promotions and then match the call 

statement with function prototype. 

 

3. List the rules for function overloading [ June – 10, Oct – 10, Oct-14, Oct-15] 

Rules for function overloading: 

1) Each overloaded function must differ either by the number of its formal 

parameters or their data types 

2) The return type of overloaded functions may or may not be the same data type 

3) The default arguments of overloaded functions are not considered by the C++ 

compiler as part of the parameter list 

4) Do not use the same function name for two unrelated functions 

 

4. What is operator overloading [Mar – 09, Oct – 11, Oct – 13, Oct – 12, June-14, Mar-

15, Mar-16, Oct-16] 

Operator overloading: 

� The mechanism of giving special meaning to an operator is called as 

operator overloading. 

� The term operator overloading, refers to giving additional functionality to the 

normal C++ operators like +,++,-,—,+=,-=,*.<,>. 

� The functionality of ‘+’ operator can be extended to strings through operator 

overloading. 
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5. List out the operators that cannot be overloaded [Oct – 07, June – 08] 

One cannot overload C++ specific operators like  

i) membership operator (.) 

ii) scope resolution operator (::) 

iii) sizeof operator and  

iv) conditional operator (?:) 

 

6. What are the various process invoked in operator overloading [Mar – 08] 

The process of overloading involves: 

� Create a class that defines the data type that is to be used in the overloading 

operations. 

� Declare the operator function operator () in the public part of the class. 

� Define the operator function to implement the required operations. 

 

7. Mention any two rules for operator overloading [June – 09, June-16] 

Rules for overloading operators: 

� Only existing operators can be overloaded. New operators cannot be created. 

� The overloaded operator must have at least one operand of user defined type. 

� Binary operators overloaded through a member function take one explicit 

argument. 

8. What is polymorphism? 

Polymorphism: 

� The word polymorphism means many forms (poly – many, morph – shapes).  

� The ability of an object to respond differently to different messages is called as 

polymorphism. 

� In C++, polymorphism is achieved through function overloading and operator 

overloading. 

9. Define the term overloading. 

Overloading: 

� The term overloading means a name having two or more distinct meanings.  

� Thus an ‘overloaded function’ refers to a function having more than one 

distinct meaning. 

 

10. Write the possible integral promotions in C++. 

� Integral promotions are purely compiler oriented. By and large integral 

promotions are as follows: 

� char data type can be converted to integer/float/double 

� int data type can be converted to char/double/float 

� float data type to integer/double/char 

� double data type to float or integer 
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8.CONSTRUCTORS AND DESTRUCTORS 

1. Tabulate any two difference between constructor & destructor [Mar – 09, Oct – 13] 

Difference between constructor & destructor: 

S.NO. Constructor Destructor 

1. 

When an instance of a class comes 

into scope, a special function called 

the constructor gets executed. 

When an instance of a class goes out 

of scope, a special function called the 

constructor gets executed. 

2. 
A constructor can have parameter 

list 
The destructor cannot have arguments 

3. 
A constructor is a function that 

allocates the memory of an object 

A destructor is a function that 

removes the memory of an object 

 

2. What are the function of a constructor [Oct – 07, June – 08, Oct – 10, Mar – 11,          

Mar–12, Oct – 12, Mar – 13, Mar-14, June-14, Mar-15, Oct-16, Mar-17] 

Functions of constructor 

1) The constructor function initializes the class object. 

2) The memory space is allocated to an object. 

 

3. When is copy constructor executed [June – 07, Oct – 09, June – 10, June – 11, June-16] 

Copy constructor: 

� The constructor add (add &a ) is called as copy constructor.  
A copy constructor is executed: 

1) When an object is passed as a parameter to any of the member functions 
Example void add::putdata( add x); 

2) When a member function returns an object 
For example, add getdata(); 

3) When an object is passed by reference to constructor 
For example, add a; b(a); 
 

4. Write the rules for constructor definition and usage [Mar – 07, June – 09, Oct – 11, 

June-13, Mar-16] 

Rules for constructor definition and usage 

1. The name of the constructor must be same as that of the class. 

2. A constructor can have parameter list. 

3. It has no return type. 

4. The constructor function can be overloaded. 

5. The compiler generates a constructor, in the absence of a user defined constructor. 

6. The constructor is executed automatically. 
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5. Write the rules for destructor definition & usage [Mar – 10] 

Rules for destructor definition and usage 

1. The destructor has the same name, also prefixed by the tilde character ‘~’. 
2. The destructor cannot have arguments. 
3. It has no return type. 
4. Destructors cannot be overloaded i.e., there can be only one destructor in a class. 
5. The compiler generates a destructor, in the absence of a user defined destructor. 

6. The destructor is executed automatically when the control reaches the end of 
class scope. 

 

6. What is destructor? Give example. [June-15, Oct-15] 

Destructor: 

� When an instance of a class goes out of scope, a special function called the 

constructor gets executed. 

� A destructor is a function that removes the memory of an object which was 

allocated by the constructor at the time of creating a object. 

� It carries the same name as the class tag, but with a tilde ( ~) as prefix. 

� The destructor functions return nothing. It not associated with any data type. 

For example : 

class simple 
{ 
public : 
~simple() 
{ 
....................... 
} 
}; 

7. What is constructor? Give example. . (or) What is default constructor? (or) What is 
non-parameterized constructor? [Oct-14] 

Constructor: 

� When an instance of a class comes into scope, a special function called the 

constructor gets executed.  

� The constructor function initializes the class object. 

� The constructor function name has the same name as the class tag.  

� The constructor functions return nothing. It not associated with any data type. 

For example : 

class simple 

{ 

public : 

simple() 

{ 

....................... 

} 

}; 
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8. What is constructor overloading?   (or)   How the constructors can overload? 

Constructor overloading: 

� Function overloading can be applied for constructors, as constructors are special 

functions of classes. 

� Constructors can be overloaded in the following three form of constructor. 
i) non-parameterized constructor 
ii) parameterized constructor 
iii) copy constructor 
 

9. Match the following for the class ‘myclass’. 

(i) myclass()   - a) copy constructor 

(ii) myclass(int x, int y) - b) method 

(iii) void show()   - c) default constructor 

(iv) myclass(myclass&a) - d) parameterized constructor 

Solution: 

(i) myclass()   - default constructor  

(ii) myclass(int x, int y) - parameterized constructor 

(iii) void show()   - method  

(iv) myclass(myclass&a) - copy constructor 

 

10. Find the errors of the following C++ program. 
class simple 
{ 
private: 
int x; 
simple() 
{ 
x=5; 
} 
}; 

 Solution: 

� The constructor simple() is not accessed, because constructor is declared under 
private visibility mode in the given program.  

� The constructor and destructor must declare under public visibility mode only. 

Correct Program: 

class simple 
{ 
public: 
int x; 
simple() 
{ 
x=5; 
} 
}; 
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9.INHERITANCE 

1. What are the advantages of inheritance [Oct – 07, Mar – 09, Oct – 10, Mar – 11,          

Mar – 13, Oct – 13, Mar-14, Mar-16, Mar-17] 

Advantages of inheritance: 

1. Reusability of code :  

� Many applications are developed in an organization. Code developed for one 

application can be reused in another application if such functionality is required.  

� This saves a lot of development time. 

2. Code sharing :  

� The methods of the base class can be shared by the derived class. 

3. Consistency of interface:  

� The inherited attributes and methods provide a similar interface to the calling 

methods.  

 

2. Write the syntax for creating a derived class from a base class [Mar – 08, Oct – 09, 

June-15] 

Syntax for creating a derived class from a base class: 

class der_name : visibility_mode base_class-id 

{ 

data members of the derived_class 

functions members of derived_class 

} 

 

3. What is the abstract class [June – 08, Mar – 12, June – 12, June – 13, Oct-14] 

Abstract class: 

� Classes used only for deriving other classes are called as Abstract Classes.  

� That is to say that objects for these classes are not declared. 

 

4. What is accessibility (or)  In C++ what is meant by visibility mode? [June – 10, Oct – 

12, Mar-15, June-16] 

Accessibility: 

� An important feature in Inheritance is to know as to when a member of a base 

class can be used by the objects or the members of the derived class. This is 

called as accessibility.  

� The three access specifiers are private, protected and public.  

� Access specifier is also referred to as visibility mode. The default visibility 

mode is private. 
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5. What are the three access specifiers used to inherit a derived class [Oct – 08] 

Access specifiers used to inherit a derived class: 

� The three access specifiers are used to inherit a derived class is  

i) private 

ii) protected and  

iii) public.  

� Access specifier is also referred to as visibility mode. 

� The default visibility mode is private 

 

6. What are the different types of inheritance [Mar – 07, June – 07, Mar – 10, Oct – 11, 

Oct-15, Oct-16] 

Types of inheritance: 

� Classes can be derived from classes that are themselves derived. There are 

different types of inheritance viz.,  

1. Single Inheritance 

2. Multiple inheritance 

3. Multilevel inheritance 

4. hybrid inheritance and 

5. hierarchical inheritance. 

 

7. What is multilevel inheritance [June – 09, June – 11] 

Multilevel Inheritance: 

� The transitive nature of inheritance is reflected by this form of inheritance.  

� When a class is derived from a class which is a derived class itself – then this is 

referred to as multilevel inheritance. 

 

BASE CLASS – GRAND FATHER 
 
 

DERIVED – FATHER 
 
 

DERIVED – CHILD 
 
 

8. What is inheritance? [June-14] 

Inheritance: 

� Inheritance is the most powerful feature of an object oriented programming 

language.  

� Inheritance is a process of creating new classes called derived classes, from the 

existing or base classes.  

� The derived class inherits all the properties of the base class.  
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9. What are the points should be observed while defining a derived class? 

� While defining a derived class, the following points should be observed 

a. The keyword class has to be used 

b. The name of the derived class is to be given after the keyword class 

c. A single colon 

d. The type of derivation, namely private, public or protected 

e. The name of the base class or parent class 

f. The remainder of the derived class definition 

 

10. What is single inheritance? 

Single inheritance: 

� When a derived class inherits only from one base class, it is known as single 

inheritance. 

 

Base class – Employee 

 

 

 

Derived class – Manager 

 

 

11. What is multiple inheritance? 

Multiple inheritance: 

� When a derived class inherits from multiple base classes it is known as multiple 

inheritance. 

 

Base class – Address    Base class - Office 

 

 

 

 

Derived class – Manager 
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10.IMPACT OF COMPUTERS ON SOCIETY 
1. What are the three technical elements a common man need to reach out the benefits of 

IT [June – 13] 

� To reach out the benefits of IT to the common man we need at least three 

technical elements : 

1. Connectivity [Computer networks and Internet facility] 

2. Affordable computers or other similar devices 

3. Software 

 

2. What is ATM [Mar – 08, Oct – 12] 

ATM: 

� ATM enable withdrawal of money from the accounts in a particular bank 

anytime and anywhere.  

� This helps the user in emergency situations where money is needed during the 

nights and holidays. However, the user has to go to the nearest ATM facility.  

 

3. What is meant by emotions containers [Oct – 11] 

Emotions containers: 

� They are small compartments with a screen, speaker and a scent to derive 

emotional comfort.  

� This can prevent people from acquiring bad habits 

 

4. What is e – banking [Mar – 09, Mar – 11] 

e – banking: 

� e-Banking permits banking from the comfort of the home by using internet 

facilities.  

� It has truly improved the reach and services of banks. 

 

5. How are computers used in education [June – 10] 

Computers are used in many areas of Education including: 

� Buying and browsing the latest edition of books by both local & foreign authors 

Educational CDROMs 

� Computer Based Tutorials (CBT). 

� Spreading information about schools, colleges, universities and courses offered, 

admission procedures, accommodation facilities, scholarships, educational 

loans, career guidance. 

� e-Learning that enables online educational programs leading to degrees and 

certifications. 
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6. What is meant by e – learning [Mar – 07, Mar-15, June-15] 

e-Learning: 

� e-Learning that enables online educational programs leading to degrees and 

certifications. 

 

7. What is e-shopping? [Oct-15] 

e-shopping: 

� Computers are used in many areas even for Shopping.  

� You can purchase any product, any brand, and any quantity from anywhere 

through e-shopping.  

� Credit cards and prior registration with the shop are the popular methods. The 

items purchased will be delivered at your home. 

 

 

11.IT ENABLED SERVICES 
1. Write a note on e-governance. [Mar-14, Oct-16] 

e-governance: 

� The various websites provided by the government give the details about the 

departments, specific functions, special schemes, documents, contacts, links, IAS 

intranet, site map, search, what’s new, press releases, feedback.  

� These websites are both in English and Tamil. 

 

2. What is IT enabled services [Mar – 09] 

IT enabled services: 

� Information Technology that helps in improving the quality of service to the 

users is called IT Enabled Services [ITES].  

� IT Enabled Services are human intensive services that are delivered over 

telecommunication networks or the Internet to a range of business segments.  

� ITES greatly increases the employment opportunities. 

 

3. Write any four IT enabled series [Oct – 13] 

IT enabled services: 

� Information Technology that helps in improving the quality of service to the 

users is called IT Enabled Services [ITES].  

Some of the IT enabled services  

1. e-Governance 

2. Call Centers 

3. Data Management 

4. Medical [Telemedicine and Transcription]. 

5. Data Digitization 

6. Website Services 

 

www.Padasalai.Net                                             www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



J.P.MURUGAN, M.Sc.,B.Ed.,  CELL:9488832229            Page 102 

 

4. What is the use of call centers [June – 07, Oct – 09, June – 12, Mar-16]   (or) 

What is call centers [Mar – 10, Oct – 10, June – 11, Mar-17] 

Call centers: 

� A call center is sometimes defined as a telephone based shared service center for 

specific customer activities and are used for number of customer-related functions like 

marketing, selling, information transfer, advice, technical support and so on.  

� A call center has adequate telecom facilities, trained consultants, access to wide 

database, Internet and other on-line information support to provide information and 

support services to customers.  

� It operates to provide round the clock and year round service i.e.24 x 365 service. 

5. Define data management [Oct – 07, June – 12] 

Data management: 

� Data Management is a category of IT Enabled Services pertaining to collection, 

digitization and processing of data coming from various sources.  

� Traditional data processing services comprise punching data from manually filled 

forms, images or publications; preparing databases and putting them together.  

� Data management is the key for effective and profitable use of IT in organizations. 

 

6. What is medical transcription? [June – 08, Oct-14] 

Medical transcription: 

� Medical Transcription is a permanent, legal document that formally states the 

result of a medical investigation.  

� It facilitates communication and supports the insurance claims.  

� There are three main steps involved in Medical Transcription. 

 

7. What is data digitization? [Oct – 08, June – 09, Mar – 13, June-16] 

Data digitization: 

� Digitization refers to the conversion of non-digital material to digital form.  

� A wide variety of materials as diverse as maps, manuscripts, moving images 

and sound may be digitized. 

 

8. Write the benefits of data digitization [June – 08] 

Benefits of data digitization: 

� Long term preservation of the documents. 

� Storage of important documents at one place. 

� Easy to use and access to the information. 

� Easy transfer of information in terms of images and text. 

� Easy transfer of information through CD-ROM, internet and other electronic media 

9. What is Dicta phone? 

Dicta phone: 

� A facility that allows the user to speak into a special device called ‘Dictaphone’ 

and then convert the speech into a letter is an ITES. 
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12.COMPUETR ETHICS 

1. Define computer ethics [Oct – 11] 

Computer ethics: 

� Computer ethics is the set of rules for determining moral standards or what is 

considered as socially acceptable behaviors. 

 

2. What is computer crime? Write any two points. [June – 09, Oct – 10, Mar – 13,         

Mar-14, Mar-17] 

Computer crime: 

� A computer crime is any illegal activity using computer software, data or access 

as the object, subject or instrument of the crime. 

 

Some common computer crimes, 

1. Stealing hardware 

2. Virus 

3. Cracking 

4. Theft of computer time 

 

3. List out the common computer crimes [Mar – 07] 

Common computer crimes: 

1. Crimes related to money transfer on the internet 

2. Making long distance calls illegally using computers 

3. Illegal access to confidential files 

4. Stealing hardware 

5. Selling or misusing personal 

6. Hardware and software piracy 

7. Virus 

8. Cracking 

9. Theft of computer time 

 

4. Write a note on Virus [Oct – 07, Mar – 10, June – 13, Oct – 12, June-14, Mar-16, 

Oct-16] 

Virus: 

� A virus is a self-replicating program that can cause damage to data and files 

stored on your computer.  

� 57000 known virus programs are in existence. 6 new viruses are found each day. 

5. What is meant by piracy [June – 07, June – 11] 

Piracy: 

� Making and using duplicate hardware and software is called piracy. 
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6. What is meant by theft of computer time [June – 10, Mar – 11, Oct-14, Mar-15] 

Theft of computer time: 

� The idle time of computers in an organization is being stolen illegally.  

� Some other software runs on an idle computer without the knowledge of the 

organization. This is called theft of ‘computer time’. 

 

7. Define cracking [Mar – 08, Oct – 08, Oct – 09, Mar – 12, June-14, Oct-15, June-16] 

Cracking: 

� Cracking is the illegal access to the network or computer system. 

� Illegal use of special resources in the system is the key reason for cracking.  

 

8. List out the data security methods. (or) What are the types of data security? [June-15] 

Types of data security: 

� There are three ways to protect our personal data in computer systems. 

1. Physical Security: 

� Physical security refers to the protection of hardware, facilities, magnetic disks, 

and other items that could be illegally accessed, stolen, damaged or destroyed.  

2. Personal Security: 

� Personal security refers to software setups that permit only authorized access to 

the system.  

3. Personnel Security: 

� Personnel security refers to protecting data and computer system against 

dishonesty or negligence of employees. 
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II. Five Mark Questions: 
 

3.BASIC STATEMENT 
1. Explain simple if statement with an example.  

Simple if statement: 

� Simple if statement is a one way decision making statement. It is used to control 

the flow of execution of the statement. 

� And also used to test logically to find whether the condition is true or false 

Syntax: 

 if(condition / expression) 

 { 

 action block; 

 } 

� If there is only one statement in the if block, the braces { } are optional. 

� If you want more than one statements in if block, braces { } are compulsory. 

Flow chart: 

 

     True          False 

      Condition 

     

 

  Action block     Out of the if statement 

     

 For example, 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int a; 

 cout<<”ENTER YOUR VALUE\n”; 

 cin>>a; 

 if(a > 0) 

 cout<<”YOUR NUMBER IS GREATER THAN ZERO\n”; 

 getch(); 

 } 

 Manual execution: 

 Input: 

  ENTER YOUR VALUE 
  10 
 Output: 

  YOUR NUMBER IS GREATER THAN ZERO 
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2. Explain if-else statement with an example.  

if-else statement:  

� if-else statement is a two way decision making statements.  And also used to test 

logically to find whether the condition is true or false. 

� “if – else statement which chooses between two alternatives , executes the chosen 

block based on the condition”. 

Syntax: 

 if(condition / expression) 

 { 

 action block 1; 

 } 

 else 

 { 

 action block 2; 

 } 

� If there is only one statement in the if block or else block, the braces { } are 

optional. 

� If you want more than one statements in if block or else block, braces { } are 

compulsory. 

 

 

Flow chart: 

 

     True          False 

      Condition 

     

 

                 Action block 1                     Action block 2 

                      (if part)                                  (else part)  

  

 

     

        End 

 For example, 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int a,b; 

 cout<<”ENTER THE VALUE OF A\n”; 

 cin>>a; 
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cout<<”ENTER THE VALUE OF B\n”; 

 cin>>b; 

 if(a > b) 

 cout<<”THE VALUE OF A IS GREATER THAN B\n”; 

else 

cout<<” THE VALUE OF B IS GREATER THAN A\n”; 

 getch(); 

 } 

 

 Manual execution: 

 Input: 

  ENTER THE VALUE OF A 
  20 
  ENTER THE VALUE OF B 
  10 

Process: 

if (20>10)                  True 

Output: 

  THE VALUE OF A IS GREATER THAN B 

 

3. Explain nested if statement with an example.  

Nested if statement:  

� The statement sequence of if or else may contain another if statement. That is        

if .. else statements can be nested within one another is called nested if statement. 

� In an nested if .. else statement, “Each else matches with the nearest 

unmatched preceding if” 

Syntax: 

 if(condition 1 / expression 1) 

 if (condition 2 / expression 2) 

 { 

 action block 1; 

 } 

 else 

 { 

 action block 2; 

 } 

 else 

 { 
 action block 3; 
 } 

� If there is only one statement in the if block or else block, braces { } are optional. 

� If you want more than one statements in if block or else block, braces { } are 

compulsory. 
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Flow chart: 
 

                  False 

      Condition 1 

     

                                                             True        

                                            Action block 3 

                                         (else part) 

 

 True                                          False  

Condition 2 

     

 

         Action block 1           Action block 2 

              (if part)                (else part) 

 

 

        End 

 For example, 

 #include<iostream.h> 
 #include<conio.h> 
 void main() 
 { 
 clrscr(); 
 int a; 
 cout<<”ENTER YOUR TENTH AVERAGE MARK\n”; 
 cin>>a; 
 if((a >=60) 
 if( a>=90) 

cout<<” FIRST CLASS WITH DISTINCTION\n”; 
else 
cout<<” FIRST CLASS\n”; 
else 
cout<<” SECOND CLASS\n”; 

 getch(); 
 } 

 Manual execution: 

 Input: 

  ENTER YOUR TENTH AVERAGE MARK 
  96 
 Process: 

if ((96>=60)           True 

if(96>=90)                    True 
Output: 

  FIRST CLASS WITH DISTINCTION 
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4. Explain switch statement with an example.  

Switch Statement:  

� Switch statement is a multiple branching statement where, based on a condition, 

the control is transferred to one of the many possible points. 

� switch creates branches for multiple alternatives sections of code, depending on 

the value of a single variable. 

� ”Switch selection expression must be of integral type “which means that switch 

expression should be evaluated to an integer constant only (char, enum,int). 

Syntax: 

 switch(expression 1) 

 { 

case 1: action block 1; 

  break; 

case 2: action block 2; 

  break; 

case 3: action block 3; 

  break; 

default: action block 4; 

} 

 

� Every action block should be terminated with a break statement. Otherwise all 

action blocks are executed sequentially from the point where the control has been 

transferred based on the condition. 

 

Flow chart: 

      switch(expression) 

       case 1: action block 1; 

        break; 

case 2: action block 2; 

        break; 

case 3: action block 3; 

        break; 

           

 

 

default: action block 4; 

� Include break; in action block, in order to exit from switch statement.   
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For example, 

 #include<iostream.h> 
#include<conio.h> 

 void main() 
 { 
 clrscr(); 
 int a; 
 cout<<”ENTER THE VALUE OF A\n”; 
 cin>>a; 
 cout<<”THAT NUMBER IS\n”; 
 switch(a) 
 { 

case 1: cout<<”ONE”; 
  break; 
case 2: cout<<”TWO”; 
  break; 
case 3: cout<<”THREE”; 
  break; 
case 4: cout<<”FOUR”; 
  break; 
case 5: cout<<”FIVE”; 
  break; 
default: cout<<”YOUR NUMBER IS WRONG”; 
} 
getch(); 
} 

Manual execution: 

Input: 

ENTER THE VALUE OF A 
3 
Output: 

THAT NUMBER IS THREE 
 

5. Explain while loop with an example (or) Explain entry check loop with an example.  
While loop: 

� While loop is also called as entry check loop.The body of the while loop will be 

executed only if the test expression results true placed in the while statement. 

� The control exits the loop once the test expression evaluated to false. 

 

Syntax: 

 while(condition) 

 { 

 …………..... 

 body of the loop; 

 ……………. 

 } 
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� The body of the loop has one or more statement. 

� The blocking with braces is needed only if the body of the loop contains two or 

more statements. 

 

Flow chart: 

                                                                False 

                                            condition 

 

                 True 

 

 

         Body of the loop 

 

        Out of the loop 

 

For example: 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int n, s = 0, i = 1; 

 cout<<”ENTER THE VALUE OF N\n”; 

 cin>>n; 

 while(i<=n) 

 { 

 s = s + i; 

 i = i + 1; 

 } 

 cout<<”THE RESULT IS\n”; 

 cout<<s; 

 getch(); 

 } 

Manual execution: 

Input: 

 ENTER THE VLAUE OF N 

 5 

Output: 

 THE RESULT IS 

 15 
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6. Explain for loop with an example (or) Explain entry controlled loop with an example. 

(or) Discuss about the general working of for loop in C++.  

for (; ; ) .. loop: 

� for (; ; ) loop is an entry controlled loop. It is used when an action is to be 

repeated for a predetermined number of times.  

� The body of the for loop is executed only if the test expression results is true 

placed in the for statement. 

� The control exits the loop once the test expression evaluated to false. 

Syntax: 

for(intial value ; test-condition ; increment) 

{ 

action block; 

} 

� The body of the loop has one or more statement. The blocking with braces are 

needed only if the contains two or more statements. 

Flow chart: 

 

 

                                          Initial value                   

 

                                                                False 

                                            condition 

 
                 True 

 

         Body of the loop 

 

 

              Increment   Out of the loop 

 

 

 

The general working of for(;;)loop is : 

� The control variable is initialized the first time when the control enters the loop 

for the first time. 

� Test condition is evaluated. The body of the loop is executed only if the condition 

is TRUE. Hence for(;;) loop is called as entry controlled loop. 

� On repetition of the loop, the control variable is incremented and the test 

condition will be evaluated before the body of the loop is executed. 

� The loop is terminated when the test condition evaluates to false. 
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For example: 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int n, s = 0; 

 cout<<”ENTER THE VALUE OF N\n”; 

 cin>>n; 

 for(int i=1; i<=n; i++) 

 s = s + i; 

 cout<<”THE RESULT IS\n”; 

 cout<<s; 

 getch(); 

 } 

 

Manual execution: 

Input: 

 ENTER THE VLAUE OF N 

 5 

Output: 

 THE RESULT IS 

 15 

    From the above example program we know that, 

for(int i = 1; i<=5; i++) 

 

Increment (1st segment) 

Test condition (2nd segment) 

Initialization of control variable (3rd segment) 

 

 

7. Explain do-while loop with an example (or) Explain exit check loop with an example.  

do-while loop: 

� do … while <(condition)> is called as exit- check loop, as the condition(test 

expression) marks the last statement of the body of the loop. 

� The body of the do-while loop is executed at least once, if the irrespective of the 

test expression. 

� In the do-while loop, the body of the loop is executed first and after that the 

condition will be evaluated.  

� Body of the loop repeatedly executed until the condition becomes false. 
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Syntax: 

 do 
 { 
 …………..... 
 body of the loop; 
 ……………. 
 } while(condition); 
 

� The body of the loop has one or more statement. 

� The blocking with braces is needed only if the body of the loop contains two or 

more statements. 

Flow chart: 

                                                 do  

 

 

                          

                                      Body of the loop 

 

                              True                               

                                            condition 

 

                 False 

 

    Out of the loop 

For example: 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int n, s = 0, i = 1; 

 cout<<”ENTER THE VALUE OF N\n”; 

 cin>>n; 

 do  

 { 

 s = s + i; 

 i = i + 1; 

 } while(i<=n) 

 cout<<”THE RESULT IS\n”; 

 cout<<s; 

 getch(); 

 } 
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Manual execution: 

Input: 

 ENTER THE VLAUE OF N 

 5 

Output: 

 THE RESULT IS 

 15 

      From the above example program, we know that the condition is true, so the loop is 

executed 5 times based on the input.  

 

 

8. Define if statement. Explain with an example.  

if statement:  

� if statement is the simplest of all the decision statements. It is implemented in 

two forms. 

1. Simple if statement 

2. if .. else statement 

 

1. Simple if statement: 

� Simple if statement is a one way decision making statement. It is used to control 

the flow of execution of the statement. 

 

Syntax: 

 if(condition / expression) 

 { 

 action block; 

 } 

  

For example, 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int a; 

 cout<<”ENTER YOUR VALUE\n”; 

 cin>>a; 

 if(a > 0) 

 cout<<”YOUR NUMBER IS GREATER THAN ZERO\n”; 

 getch(); 

 } 
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 2. if-else statement:  

� if-else statement is a two way decision making statements.  And also used to test 

logically to find whether the condition is true or false. 

� “if – else statement which chooses between two alternatives , executes the chosen 

block based on the condition”. 

Syntax: 

 if(condition / expression) 

 { 

 action block 1; 

 } 

 else 

 { 

 action block 2; 

 } 

 For example, 

 #include<iostream.h> 

 #include<conio.h> 

 void main() 

 { 

 clrscr(); 

 int a,b; 

 cout<<”ENTER THE VALUE OF A\n”; 

 cin>>a; 

cout<<”ENTER THE VALUE OF B\n”; 

 cin>>b; 

 if(a > b) 

 cout<<”THE VALUE OF A IS GREATER THAN B\n”; 

else 

cout<<” THE VALUE OF B IS GREATER THAN A\n”; 

 getch(); 

 } 
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4.FUNCTIONS 

 
1. What are the functions? Explain with an example. 

Functions: 

� Functions are the building blocks of C++ programs. Functions are also the 

executable segments in a program.  

� The starting point for the execution of a program is main ( ). 

 

Advantages of functions: 

� Reduce the size of the program. 

� Induce reusability of code. 

� A function can be shared by other programs by compiling it separately and 

loading them together. 

 

General syntax: 

 data_type   function_identifier(arguments) 

 { 

 function block; 

 return; 

 } 

� return statement marks the end of the function and also transfers control to the 

statement after call statement.   

 

 For example, 

  #include<iostream.h> 

  #include<conio.h> 

  int sum( int x, int y) 

{ 

return x+y; 

} 

void main() 

{ 

clrscr(); 

int a=10, b=5, s=0; 

s=sum(a,b); 

cout<<”THE RESULT IS…..\n”<<s; 

getch(); 

} 
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2. Explain inline function with an example. 

Inline Functions: 

� An inline function looks like a normal function in the source file but inserts the 

function’s code directly into the calling program. 

� Inline function execute faster but require more memory space. 

� To make a function inline, one has to insert the keyword inline in the  

function header.  

 

Advantages of inline functions: 

� Reusability of code leading to saving of memory space and 

� Reduction in code size. 

 

General syntax: 

 inline data_type   function_identifier(arguments) 

 { 

 function block; 

 return; 

 } 

� return statement marks the end of the function and also transfers control to the 

statement after call statement.   

 

For example, 

  #include<iostream.h> 

  #include<conio.h> 

  inline int sum( int x, int y) 

{ 

return x+y; 

} 

void main() 

{ 

clrscr(); 

int a=10, b=5; 

cout<<”THE RESULT IS…..\n”<< sum(a,b); 

getch(); 

} 
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3. Explain call by value method with suitable example. 

Call by value method: 

� In this method, the called function creates new variables to store the value of the 

arguments passed to it. 

� This method copies the values of actual parameters into the formal parameters, 

thus the function creates its own copy of arguments and then uses them. 

� “In call by value method, any change made in the formal parameter is not 

reflected back to the actual parameter.” 

For example, 

 #include<iostream.h> 

 #include<conio.h> 

void swap(int x, int y) 

{ 

int t; 

t = x; 

x = y; 

y = x; 

cout<<”CALLING SWAP FUNCTION\n”; 

cout<<x<<”\t”<<y; 

} 

void main() 

{ 

clrscr(); 

int a=10, b=20; 

cout<<”BEFORE CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

swap(a,b); 

cout<<”AFTER CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

getch(); 

} 

 Manual execution: 

BEFORE CALLING SWAP FUNCTION 

10        20 

CALLING SWAP FUNCTION 

20        10 

AFTER CALLING SWAP FUNCTION 

10        20 

� The modifications made to formal parameters are not reflected in actual 

parameters, because formal and actual parameters in value type point to the 

different storage area. 
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4. Explain call by reference method with suitable example. 

Call by reference method: 

� In this method, the called function arguments - formal parameters become alias to 

the actual parameters in the calling function. 

� This means that when the function is working with its own arguments, it is 

actually working on the original data. 

� “In call by reference method, any change made in the formal parameter is 

reflected back to the actual parameter.” 

For example, 

 #include<iostream.h> 

 #include<conio.h> 

void swap(int &x, int &y) 

{ 

int t; 

t = x; 

x = y; 

y = x; 

cout<<”CALLING SWAP FUNCTION\n”; 

cout<<x<<”\t”<<y; 

} 

void main() 

{ 

clrscr(); 

int a=10, b=20; 

cout<<”BEFORE CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

swap(a,b); 

cout<<”AFTER CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

getch(); 

} 

 Manual execution: 

BEFORE CALLING SWAP FUNCTION 

10        20 

CALLING SWAP FUNCTION 

20        10 

AFTER CALLING SWAP FUNCTION 

20        10 

 

� The modifications made to formal parameters are reflected in actual parameters, 

because formal and actual parameters in reference type point to the same storage 

area. 
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5. Define scope. Explain the various types of scopes in C++. (or) How many types of 

variable scopes are there in C++? Explain them with sample snippet.   

Type of scope rules of variables: 

� Scope refers to the accessibility of a variable.  

� There are four types of scopes in C++. They are, 

1. Local scope  

2. Function scope 

3. File scope  

4. Class scope 

Local scope: 

� A local variable is defined within a block. 

� The scope of a local variable is the block in which it is defined. 

� A local variable cannot be accessed from outside the block of its declaration. 

� Local variables are not known outside their own code block. A block of code 

begins and ends with curly braces { }. 

� Local variables exist only while the block of code in which they are declared is 

executing. 

� The life time of a local scope variable is the life time of the block in its state of 

execution. 

� Local variable are die when its block execution is completed. 

� A local variable is created upon entry into its block and destroyed upon exit. 

Function scope 

� The scope of variables declared within a function is extended to the function 

block, and all sub-blocks therein. 

� The variable is accessible in the function main ( ) only. It is accessible in all the 

sub-blocks therein - viz, while block & if block. 

� The life time of a function scope variable is the life time of the function block.  

� The scope of formal parameters is function scope. 

File scope: 

� A variable declared above all blocks and functions (precisely above main ( ) ) has 

the scope of a file.  

� The scope of a file scope variable is the entire program.  

� The life time of a file scope variable is the life time of a program. 

Class scope: 

� The data variables declared within the class has the scope of a class. 

� Their scope will be decided by the access specifier private, protected, public. 

� The life time of a class scope variable is the life time of the class.  

Scope Operator: 

� The scope operator reveals the hidden scope of a variable. 

� :: is called as scope resolution operator.  

� It is used to refer variables declared at file level.  
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For example, 

#include<iostream.h> 

#include<conio.h> 

const int n = 5; 

class student 

{ 

public: 

int s = 0; 

void sum(int m) 

{ 

for(int i=1; i<=m; i++) 

s=s+i; 

cout<<”THE RESULT IS\n”; 

cout<<s; 

} 

}; 

void main() 

{ 

clrscr(); 

student stud; 

stud.sum(n); 

getch(); 

} 

 

From the above example program, Scopes of a variables are 

S.No Scope Variable 

1. File n 

2. Class s 

3. Function m 

4. Local i 

 

6. Explain the types of parameters passing in function. [Oct – 11]   (or) How many ways, 

functions that have arguments can be invoked in C++? Explain. 

Parameters passing in function: 

� The call statement communicates with the function through arguments or 

parameters. 

� Parameters are the channels through which data flows from the call statement to 

the function and vice versa. 

� In C++, functions that have arguments can be invoked by 

� Call by value 

� Call by reference 
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1. Call by value method: 

� In this method, the called function creates new variables to store the value of the 

arguments passed to it. 

� “In call by value method, any change made in the formal parameter is not 

reflected back to the actual parameter.” 

For example, 

 #include<iostream.h> 

 #include<conio.h> 

void swap(int x, int y) 

{ 

int t; 

t = x; 

x = y; 

y = x; 

cout<<”CALLING SWAP FUNCTION\n”; 

cout<<x<<”\t”<<y; 

} 

void main() 

{ 

clrscr(); 

int a=10, b=20; 

cout<<”BEFORE CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

swap(a,b); 

cout<<”AFTER CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

getch(); 

} 

 Manual execution: 

BEFORE CALLING SWAP FUNCTION 

10        20 

CALLING SWAP FUNCTION 

20        10 

AFTER CALLING SWAP FUNCTION 

10        20 

2. Call by reference method: 

� In this method, the called function arguments - formal parameters become alias to 

the actual parameters in the calling function. 

� “In call by reference method, any change made in the formal parameter is 

reflected back to the actual parameter.” 
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For example, 

 #include<iostream.h> 

 #include<conio.h> 

void swap(int &x, int &y) 

{ 

int t; 

t = x; 

x = y; 

y = x; 

cout<<”CALLING SWAP FUNCTION\n”; 

cout<<x<<”\t”<<y; 

} 

void main() 

{ 

clrscr(); 

int a=10, b=20; 

cout<<”BEFORE CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

swap(a,b); 

cout<<”AFTER CALLING SWAP FUNCTION\n”; 

cout<<a<<”\t”<<b; 

getch(); 

} 

 Manual execution: 

BEFORE CALLING SWAP FUNCTION 

10        20 

CALLING SWAP FUNCTION 

20        10 

AFTER CALLING SWAP FUNCTION 

20        10 
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7.POLYMORPHISM 
1. What is function over loading? Explain with an example. (or) Define function 

overloading. Give an example. What are its various rules? 

Function overloading: 

� The ability of the function to process the message or data in more than one form 

is called as function overloading.  

� Thus an ‘overloded functions’ refers to a function having more than one distinct 

meaning. 

� Function overloading is one of the facets of C++ that supports object oriented 

programming. 

� The compiler adopts BEST MATCH strategy.  

For example, 

#include<iostream.h> 

#include<conio.h> 

void area(float a) 

{ 

float s; 

s = a*a; 

cout<<”\n AREA OF THE SQUARE IS:        “<<s; 

} 

void area(float l, float b) 

{ 

float s; 

s = l*b; 

cout<<”\n AREA OF THE RECTANGLE IS:        “<<s; 

} 

void area(float a, float b, float c) 

{ 

float s; 

s = a*b*c; 

cout<<”\n AREA OF THE TRIANGLE IS:        “<<s; 

} 

void main() 

{ 

clrscr(); 

int x=5, y=8; 

area(x); 

area(x,y); 

area(0.5, x, y); 

getch(); 

} 
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Manual execution: 

AREA OF THE SQUARE IS:     25 

AREA OF THE RECTANGLE IS:     40 

AREA OF THE TRIANGLE IS:     20 

 

Rules for function overloading: 

1) Each overloaded function must differ either by the number of its formal 

parameters or their data types 

2) The return type of overloaded functions may or may not be the same data type 

3) The default arguments of overloaded functions are not considered by the C++ 

compiler as part of the parameter list 

4) Do not use the same function name for two unrelated functions 

 

 

 

2. What are the rules for operator overloading?   (OR) Define operator overloading. Write 

the rules for operator overloading. 

Operator overloading: 

� The mechanism of giving special meaning to an operator is called as 

operator overloading. 

� The term operator overloading, refers to giving additional functionality to the 

normal C++ operators like +,++,-,—,+=,-=,*.<,>. 

� The functionality of ‘+’ operator can be extended to strings through operator 

overloading. 

 

Rules for overloading operators: 

There are certain restrictions and limitations in overloading operators. They are: 

� Only existing operators can be overloaded. New operators cannot be created. 

� The overloaded operator must have at least one operand of user defined type. 

� The basic definition of an operator cannot be replaced or in other words one 

cannot redefine the function of an operator. One can give additional functions to 

an operator 

� Overloaded operators behave in the same way as the basic operators in terms of 

their operands. 

� When binary operators are overloaded, the left hand object must be an object of 

the relevant class 

� Binary operators overloaded through a member function take one explicit 

argument. 
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Extra Questions: 

1. Explain the different types of inheritance. 

Inheritance: 

� Inheritance is the most powerful feature of an object oriented programming 

language.  

� It is a process of creating new classes called derived classes, from the existing or 

base classes.  

� The derived class inherits all the properties of the base class.  

Types of inheritance: 

� Classes can be derived from classes that are themselves derived. There are 

different types of inheritance viz.,  

i) Single Inheritance 

ii) Multiple inheritance 

iii) Multilevel inheritance 

iv) hybrid inheritance and 

v) hierarchical inheritance. 

 

Single inheritance: 

� When a derived class inherits only from one base class, it is known as single 

inheritance. 

 

Base class – Employee 

 

 

 

Derived class – Manager 

 

 

Multiple inheritance: 

� When a derived class inherits from multiple base classes it is known as multiple 

inheritance. 

 

Base class – Address    Base class - Office 

 

 

 

Derived class – Manager 
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Multilevel Inheritance: 

� The transitive nature of inheritance is reflected by this form of inheritance.  

� When a class is derived from a class which is a derived class itself – then this is 

referred to as multilevel inheritance. 

 

BASE CLASS – GRAND FATHER 

 

DERIVED – FATHER 

 

DERIVED - CHILD 

           

2. Write rules and usage of constructor and destructor.  

Constructor: 

� When an instance of a class comes into scope, a special function called the 

constructor gets executed. 

� A constructor is a function that allocates the memory of an object 

Rules for constructor definition and usage 

1) The name of the constructor must be same as that of the class. 

2) A constructor can have parameter list. 

3) It has no return type. 

4) The constructor function can be overloaded. 

5) The compiler generates a constructor, in the absence of a user defined constructor. 

6) The constructor is executed automatically. 

 

Destructor: 

� When an instance of a class goes out of scope, a special function called the 

constructor gets executed. 

� A destructor is a function that removes the memory of an object which was 

allocated by the constructor at the time of creating a object. 

Rules for destructor definition and usage 

1) The destructor has the same name as that of the class prefixed by the tilde 

character ‘~’. 

2) The destructor cannot have arguments. 

3) It has no return type. 

4) Destructors cannot be overloaded i.e., there can be only one destructor in a class. 

5) The compiler generates a destructor, in the absence of a user defined destructor. 

6) The destructor is executed automatically when the control reaches the end of 

class scope. 
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