COMPUTER SCIENCE
PRACTICAL MANUAL

XI STD

HIGHER SECONDARY FIRST YEAR

2017 – 2018

NAME : ..............................................................................................

CLASS : ..............................................................................................

ROLL NO : ............................................................................................

SCHOOL : .............................................................................................

## CONTENTS

### SECTION - A

**WINDOWS XP**

<table>
<thead>
<tr>
<th>Problem No</th>
<th>Problem Description</th>
<th>Page No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Working with Windows Accessories</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Working with WordPad</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Creating and Renaming a File and a Folder</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Working with Win Keys</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Working with Windows Explorer</td>
<td></td>
</tr>
</tbody>
</table>

**LINUX**

<table>
<thead>
<tr>
<th>Problem No</th>
<th>Problem Description</th>
<th>Page No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Create and Remove Directory</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Display Directory Content</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Change and Reset Password</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Sorting Data in a File</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Display Date and Time in Different Formula</td>
<td></td>
</tr>
</tbody>
</table>

**HTML**

<table>
<thead>
<tr>
<th>Problem No</th>
<th>Problem Description</th>
<th>Page No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>Display Your Name and School Address</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Display an Advertisement</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Class Time Table</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Ordered and Unordered Lists</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Display an Image and Link and URL</td>
<td></td>
</tr>
</tbody>
</table>

### SECTION - B - C PROGRAMMING

<table>
<thead>
<tr>
<th>Problem No</th>
<th>Problem Description</th>
<th>Page No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Fibonacci Series</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Number of Vowels in a String</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Adam Numbers</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Conversion Binary to Decimal</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Perfect Numbers</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Palindrome</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Descending Order</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Sum of Diagonal Elements of a Matrix</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Transpose of a Matrix</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Storing and Printing Name in an Array</td>
<td></td>
</tr>
</tbody>
</table>
EXERCISE 1:

1. Write the steps to do the following.

   a) Change the background picture (Wall paper)
   b) Change the desktop shortcut to MS paint.
   c) Convert decimal number 23 to binary, octal and hexadecimal using calculator in Scientific mode.
   d) Start MS DOS application and try DIR command with options /W, /P, /B and /L.

PROCEDURE:

   a) Step 1: Right click any-where on the blank area of the desktop.
   Step 2: Click on Properties option.
   Step 3: Select Desktop tab in Display properties dialog box. On the Background list box, select your favourite background (Wall paper).
   Step 4: Click on Apply button to change the current background and click OK button.
b) Step 1: Click on Start → All Programs → Accessories → Paint and right click.

Step 2: On the popup menu select Send To option and choose Desktop(create Shortcut)
c) Step 1: Click on **Start** → **All Programs** → **Accessories** → **Calculator**

Step 2: Select **Scientific** mode from **View** menu.

Step 3: Type the number **23** and choose **Bin** option. The binary equivalent **10111** will be displayed.

Step 4: Choose **Oct** option to convert the in Octal. The Octal equivalent **27** will be displayed.

Step 5: Choose **Hex** option to convert the number in Hexadecimal. The Hexadecimal equivalent will be displayed.
d) Step 1: Click on **Start** → **All Programs** → **Accessories** → **Command Prompt**.

Step 2: Type the command **DIR/W** to display the files and folders in Width order.

Step 3: Type the command **DIR/P** to display the files and folders in Page wise order.

Step 4: Type the command **DIR/B** to display the summary information of files and folders.

Step 5: Type the command **DIR/L** to display the files and folders name in Lower case.

**OUTPUT : 1**


**OUTPUT: 2**

Command Prompt

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\admin>DIR/B
Desktop
Favorites
My Documents
Start Menu

C:\Documents and Settings\admin>

Command Prompt

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\admin>DIR/L
Volume in drive C has no label.
Volume Serial Number is 806A-7356

Directory of C:\Documents and Settings\admin

11/09/2017 02:27 PM <DIR>   ...
11/09/2017 02:27 PM <DIR>   ...
11/15/2017 02:56 PM <DIR>   desktop
09/07/2017 12:00 PM <DIR>   favorites
11/15/2017 01:50 PM <DIR>   my documents
09/07/2017 05:18 PM <DIR>   start menu
 0 File(s)
 0 bytes
 6 Dir(s) 97,460,477,952 bytes free

C:\Documents and Settings\admin>
2. WORKING WITH WORDPAD

EXERCISE : 2

2. Write steps to do the following.
   a) Open MS Paint and draw a simple house and color it.
   b) Open WordPad, copy the picture from the paint.
   c) Type the following text below the picture.

   “Starting multiple application is very simple. First start one application
   Appears on the screen in a window. At the same time a button with name
   of the application appears on the taskbar. Now start the second application”
   d) Align the typed text to left, right center using toolbar icons and keyboard
   shortcuts.

PROCEDURE:

a) Step 1: Click on Start→ All Programs→ Accessories → Paint
   Step 2: Use Pencil or Line tool to draw a house.
   Step 3: Choose any colour from Color Palette and fill using Fill with Color tool.
   Step 4: Save the file with any name.
b) Step 1: Click on Start → All Programs → Accessories → Wordpad

Step 2: Click Insert menu and Select Object option Insert Object dialog box appears.

Step 3: Choose Create From File option and locate the file using Browse button.

Click OK button to copy the file in WordPad.

c) Step 1: Place the cursor below the picture and type the following text.

“Starting multiple application is very simple. First start one application
Appears on the screen in a window. At the same time a button with name
of the application appears on the taskbar. Now start the second application”
Starting multiple applications is very simple. First start one application appears on the screen in a window. At the same time a button with name of the application appears on the taskbar. Now start the second application.

d)
Step 1: Select the text using Mouse or Keyboard.
Step 2: Align the text to left by selecting Align Left icon from Format bar or press the keyboard shortcut Ctrl+L.
Step 3: Align the text to right by selecting Align Right icon from Format bar or press the keyboard shortcut Ctrl +R.
Step 4: Align the text to center by selecting Center icon from Format bar or press the keyboard shortcut Ctrl + E.
3. CREATING AND RENAMING A FILE AND FOLDER

EXERCISE : 3

3. Write steps to do the following.

   a) Create a text file with your school name and address using Notepad with the file name “abc.text”.

   b) Create a new folder using Windows Explorer and name the folder as “folderabc”

   c) Copy the text file abc.txt into the new folder folderabc.

   d) Rename the copies file as “xyz.txt” and folder as “folderxyz”

PROCEDURE:

a) Step 1: Click on Start ➔ All Programs ➔ Accessories ➔ Notepad

   Step 2: Type your school name and address.

   Step 3: Save the file with the name abc.txt by selecting the option Save from File menu.


![Notepad window]

APS ACADEMY MATRIC HR SEC SCHOOL,
184 KG PUDUR,
POOLUVAPATTI POST,
TIRUPUR - 641602

b) Step 1: Click on Start ➔ All Programs ➔ Accessories ➔ Windows Explorer.

   Step 2: Click on File ➔ New ➔ Folder option.
Step 3: Type the folder name **folderabc** and press Enter

c) Step 1: Locate **abc.txt** file and right click on the file name

Step 2: Choose the option **Copy**.

Step 3: Locate the folder **folderabc** and right click to select **Paste** option.
Step 1: Select the file **abc.txt** and right click the file name.

Step 2: Choose **Rename** option and type **xyz.txt**.

Step 3: Select the folder **folderxyz** and right click the folder name.

Step 4: Choose **Rename** option and type **folderxyz**.
4. WORKING WITH WINKEYS

EXERCISE : 4

4. Write the steps do the following using only keyboard (without using mouse)

   a) Display Run dialog box and open calculator.

   b) Open Explorer Window showing My computer.

   c) Display system properties dialog box.

   d) Open Help and Support Center Window

   e) Close all the above opened windows.

PROCEDURE

a) Step 1: Press Winkey + R key and type Calc

Step 2: Press Enter key to open calculator
b) **Step 1:** Press **Winkey + E** to open Explorer window showing **My Computer**.
c) Step 1: Press Winkey + Break box to display System Properties dialog box

d) Step 1: Press Winkey + F1 to open Help and Support Center Window
e) Step 1: Press Alt + F4 to close each Window

5. WORKING WITH WINDOWS EXPLORER

EXERCISE : 5

5. Write the steps to do the following.

a) Open Windows Explorer and create a new folder using Explorer bar.

b) Switch to any other folder using “Other Places” option.

c) Display the files in the folder in different views.

d) Search a particular file using windows Explorer

PROCEDURE

a) Step 1: Click on Start → All Programs → Accessories → Windows Explorer.

Select View → Explorer Bar and disable Folder option.

Step 2: Click on Make new folder under File and Folder Tasks. A new folder will be created.
b) Step 1: Click on Other Places on Explorer bar.

Step 2: Select any of the available folder.

c) Step 1: Click on Start → All Programs → Accessories → Windows Explorer

Step 2: Select View → Thumbnails option

Step 3: Select View → Tiles option.

Step 4: Select View → Icons option.

Step 5: Select View → List option.

Step 6: Select View → Details option.
d) Step 1: Click on Start ➔ All Programs ➔ Accessories ➔ Windows Explorer.

Step 2: Click on Search icon.

Step 3: Select All files and Folder option in Search Companion.

Step 4: Type the file name (xyz) to be searched.

Step 5: In Look in drop down list box, select Local Hard Drives (C: ; d: ; E; ; F;)
LINUX

6. CREATE AND REMOVE DIRECTORY

EXERCISE :6

6. Write steps to do the following.
   a) Create new directory “Folder1” using Linux commands.
   b) Create a file with file name “Lindata” and the following text.
      “Many Linux commands receive data from the Standard Input.
      You are encouraged to work with the Linux”
   c) Copy the file “Lindata” to the directory “Folder1”.
   d) Remove the file “Lindata” from the directory “Folder1”.
   e) Display the message “Linux Commands are more powerful” to the user
      (Using echo command)

PROCEDURE:

a) Step 1: Type the command `mkdir Folder1`. The directory will be created.

OUTPUT:

[unicare@localhostunicare]$ mkdir Folder1.

b) Step 1: Type the following `cat>Lindata`
   Step 2: Type the following text.
   “Many Linux commands receive data from the Standard Input.
   You are encouraged to work with the Linux”
   Step 3: Press Ctrl+Z to save the file.

OUTPUT:

[unicare@localhostunicare]$ cat>Lindata
“Many Linux commands receive data from the Standard Input.
You are encouraged to work with the Linux”
[1]+ stopped cat >Lindata
c) Step 1: Type the command `cp Lindata Folder 1`.

**OUTPUT:**

```
[unicare@localhostunicare]$ cp Lindata Folder 1.
```

d) Step 1: Type the command `cd Folder 1`.

Step 2: Now type command `rm Lindata`

**OUTPUT:**

```
[unicare@localhostunicare]$ cd Folder 1.
[unicare@localhostunicare]$ rm Folder 1.
```

e) Step 1: Type the command `echo “Linux commands are more powerful”`.

**OUTPUT:**

```
[unicare@localhostunicare]$ echo “Linux Commands are more Powerful”
Linux Commands are more Powerful
[unicare@localhostunicare]$ 
```

7. DISPLAF DIRECTROY CONTENT

EXERCISE :7

7. Write steps to display.

a) The contents of a Directory using “ls” command with any five options.

**PROCEDURE:**

a) Step 1: Type the command `$ ls –a` to display list of files including hidden files.

Step 2: Type the command `$ ls –F` to display file type along with the file name.

Step 3: Type the command `$ ls –R` to display the working directory as well as sub dir.

Step 4: Type the command `$ ls –r` to display Files/sub directory in reverse order.

Step 5: Type the command `$ls –s` to sort file by file size.

==================================================================
8. CHANGE AND RESET PASSWORD

EXERCISE: 8

7. Write steps do to the following.
   a) Change the Password of the Current User and reset the Password to original
      using Linux commands.
   b) Assign any two integer values to variables and find the sum.
   c) Clear the Screen using Linux commands.

PROCEDURE:

a) Step 1: Type the command `passwd`.
   Step 2: Type the current password.
   Step 3: Type the new password.
   Step 4: Retype the new password again. After entering the new password, a message
   is displayed as “passed all authentication tokens updated successfully”.

OUTPUT:

[unicare@localhostunicare]$ passwd
Changing password for user unicare
Changing password for unicare
(current) UNIX password:
new password:
Retype new password:
Passwd: all authentication tokens updated successfully.

b) Step 1: Type the variable `num=10`
   Step 2: Type the variable name `num=20`
   Step 3: Type the command `expr Snum1+num2`. 

OUTPUT:
[unicare@localhostunicare]$ num1=10
[unicare@localhostunicare]$ num2=20
[unicare@localhostunicare]$ expr snum1+num2
30.
[unicare@localhostunicare]$ [ ]
c) Step 1: Type the command Clear.

OUTPUT:
[unicare@localhostunicare]$ clear
[unicare@localhostunicare]$ [ ]

9. SORTING DATA IN A FILE

EXERCISE : 9

9. Write steps to do the following.

a) Create a File with five students names of your class with files names “abc”.

b) Sort the file “abc” and transfer output to another file with file name “abcsort”. (Using sort command)

c) Rename the file “abcesort” as “xyz”.

PROCEDURE:

a) Step 1: Type the command cat >abc

Step 2: Type the five students name.

Step 3: after typing, press Ctrl+Z to save the file.
b) Step 1: Type the command `sort abc | tee abcsort` to transfer the sorted content to the `abcsort` file.

```
[unicare@localhostunicare]$ sort abc | tee abcsort
Deepa
Jegan
Maya
Rahul
Swetha
```

```
[unicare@localhostunicare]$ [ ]
```

c) Step 1: Type the command `mv abcsort xyz`

Step 2: Type `ls` command to view the renamed file.

```
[unicare@localhostunicare]$ mv abcsort xyz

[unicare@localhostunicare]$ ls
```

```
evolution    lin    q    untitled 1
First project Lindata Sortcol XlEXERCISE
Folder 1 Projects sun    xyz
```

```
[unicare@localhostunicare]$ [ ]
```
**10. DISPLAY DATE AND TIME IN DIFFERENT FORMATS**

**EXERCISE :10**

10. Write procedure to display.

   a) Day of the month (in digit)
   b) Date as mm/dd/yy format.
   c) Time as HH:MM:SS
   d) Abbreviated month.
   e) Time in AM / PM notation.

**PROCEDURE:**

a)  Step 1: Type the command `date "+%d"` to display day of the month in digit.
    Step 2: Type the command `date "+%D"` to display date as mm/dd/yy format.
    Step 3: Type the command `date "+%T"` to display time as HH:MM:SS
    Step 4: Type the command `date "+%h"` to display abbreviated month.
    Step 5: Type the command `date "+%r"` to display in AM / PM notation.

**OUTPUT:**

```
[unicare@localhostunicare]$ date "+%d"
17
[unicare@localhostunicare]$ date "+%D"
11/17/2017
[unicare@localhostunicare]$ date "+%T"
12:06:54
[unicare@localhostunicare]$ date "+%h"
Nov
[unicare@localhostunicare]$ date "+%r"

```

11. DISPLAY YOUR NAME AND SCHOOL ADDRESS

**PROBLEM:**

Write a HTML code to display Name and School Address in Bold with Blue Background.

**AIM:**

To write a HTML code to display your name and School address in Bold with Blue Background.

**PROGRAM CODING:**

```html
<HTML>
<HEAD>
<TITLE>My School Address</TITLE>
</HEAD>
<BODY BGCOLOR="BLUE">
<CENTER><B>KANNAN</B><BR>
APS ACADEMY MATRIC.HR.SEC.SCHOOL<BR>
184, KG PUDUR<BR>
POOLUVAPATTI - 641603</B></CENTER>
</BODY>
</HTML>
```
12. DISPLAY AN ADVERTISEMENT

PROBLEM:

Write a HTML code to display the following advertisement as a web page and also change font, color, size to make it attractive.

“50% Discount on all Times”

“Hurry the offer is closing on 31st August”

AIM:

To write a HTML code to display the following advertisement as a web page and also change font, color, size to make it attractive.

50% Discount on all Times

“Hurry the offer is closing on 31st August”
PROGRAM CODING:

```html
<html>
<head>
<title>DISCOUNT SALE</title>
</head>
<body bgcolor="YELLOW">
<font face="ARIAL BLACK" size="5" color="GREEN">
<center>50% DISCOUNT ON ALL TIMES</center>
</font>
<font face="ARIAL NARROW" size="6" color="BLUE">
<center>"HURRY THE OFFER IS CLOSING ON 31st AUGUST"
</center>
<font face="TIME NEW ROMAN" size="7" color="RED">
<mq>
SALE! SALE! SALE!!!</mq>
</font>
</body>
</html>
```
13. CLASS TIME TABLE

PROBLEM:

Write a HTML code to display Class Time Table with cell attributes.

AIM:

To Write a html code to display your Class Time Table with cell attributes.

PROGRAM CODING:

<HTML>
<HEAD>
<TITLE>XI STD CLASS TIME TABLE </TITLE>
</HEAD>
</BODY>
<TABLE WIDTH =200 BORDER =5>
<TR BGCOLOR="RED"ALIGN="CENTER">
<TH>DAY</TH>
<TH>1</TH>
<TH>2</TH>
<TH>3</TH>
<TH>4</TH>
<TH>5</TH>
<TH>6</TH>
</TR BGCOLOUR="GREEN"ALIGN="CENTER">
<TH>MONDAY</TH>
<TD>BIOLOGY</TD>
<TD>HISTORY</TD>
<TD>PHYSICAL SCIENCE</TD>
<TD>TAMIL</TD>
<TD>ENGLISH</TD>
<TD>MATHS</TD>
</TABLE>
</HTML>
<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>TUESDAY</strong></td>
<td><strong>BIOLOGY</strong></td>
<td><strong>HISTORY</strong></td>
<td><strong>PHYSICAL SCIENCE</strong></td>
<td><strong>TAMIL</strong></td>
</tr>
<tr>
<td></td>
<td><strong>ENGLISH</strong></td>
<td></td>
<td><strong>MATHS</strong></td>
<td></td>
</tr>
<tr>
<td><strong>WEDNESDAY</strong></td>
<td><strong>BIOLOGY</strong></td>
<td></td>
<td><strong>HISTORY</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>PHYSICAL SCIENCE</strong></td>
<td><strong>TAMIL</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>ENGLISH</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>MATHS</strong></td>
</tr>
<tr>
<td><strong>THURSDAY</strong></td>
<td><strong>BIOLOGY</strong></td>
<td><strong>HISTORY</strong></td>
<td><strong>PHYSICAL SCIENCE</strong></td>
<td><strong>TAMIL</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>ENGLISH</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>MATHS</strong></td>
</tr>
<tr>
<td><strong>FRIDAY</strong></td>
<td><strong>BIOLOGY</strong></td>
<td><strong>HISTORY</strong></td>
<td><strong>PHYSICAL SCIENCE</strong></td>
<td></td>
</tr>
<tr>
<td>DAY</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
</tr>
<tr>
<td>-----------</td>
<td>------------</td>
<td>------------</td>
<td>------------</td>
<td>------------</td>
</tr>
<tr>
<td>MONDAY</td>
<td>BIOLOGY</td>
<td>HISTORY</td>
<td>PHYSICAL</td>
<td>SCIENCE</td>
</tr>
<tr>
<td>TUESDAY</td>
<td>BIOLOGY</td>
<td>HISTORY</td>
<td>PHYSICAL</td>
<td>SCIENCE</td>
</tr>
<tr>
<td>WEDNESDAY</td>
<td>BIOLOGY</td>
<td>HISTORY</td>
<td>PHYSICAL</td>
<td>SCIENCE</td>
</tr>
<tr>
<td>THURSDAY</td>
<td>BIOLOGY</td>
<td>HISTORY</td>
<td>PHYSICAL</td>
<td>SCIENCE</td>
</tr>
<tr>
<td>FRIDAY</td>
<td>BIOLOGY</td>
<td>HISTORY</td>
<td>PHYSICAL</td>
<td>SCIENCE</td>
</tr>
</tbody>
</table>
14. ORDERED AND UNORDERED LIST

PROBLEM:
Write a HTML code to create ordered and unordered list

AIM:
To Write a html code to create ordered and unordered list.

PROGRAM CODING:

```html
<HTML>
<HEAD><TITLE>ORDERED LIST</TITLE></HEAD>
<OL>
    <LI>OPERATING SYSTEM</LI>
    <LI>ARTIFICIAL INTELLIGENCE</LI>
    <LI>OBJECT ORIENTED LANGUAGE</LI>
    <LI>COMPUTER ARCHITECTURE</LI>
</OL>
<UL>
    <LI>ADVERTISING MANAGEMENT</LI>
    <LI>MANAGEMENT THOUGHTS</LI>
    <LI>SALES PROMOTION</LI>
    <LI>SERVICE MARKETING</LI>
</UL>
</BODY>
</HTML>
```
ORDERED LIST

1. OPERATING SYSTEM
2. ARTIFICIAL INTELLIGENCE
3. OBJECT ORIENTED LANGUAGE
4. COMPUTER ARCHITECTURE

UNORDERED LIST

- ADVERTISING MANAGEMENT
- MANAGEMENT THOUGHTS
- SALES PROMOTION
- SERVICE MARKETING
15. Display an Image and Link and URL

**Problem:**

Write a HTML code to display an image in a web page (using image tag) and also create hyperlink to URL- www.google.co.in.

**AIM:**

To Write a HTML code to display an image in a webpage (using image tag) and also create hyperlink to URL- www.google.co.in

**Program Coding:**

```html
<HTML>
<HEAD><TITLE><IMAGE</IMAGE>
<BODY>
<HI>SUNSET</HI>
<IMG SRC=C:\MYDOCUMENTS\SUNSET.JPG>
<A HREF="www.google.co.in">WEBSITE</A>
</BODY>
</HTML>
```

**Output:**

```html
www.Padasalai.Net
www.TrbTnpsc.com
```
SECTION -B - C PROGRAMMING

PROCEDURE FOR EXECUTING C PROGRAMS

1. To Enter A Program: Double Click the TC icon.

   File ➔ NEW

2. To Save the Program: Alt+F ➔ Save (or) F2 File name should be with the extension of C

3. To Compile the Program: ALT+C (or) ALT + F9.

4. If your coding does not have any syntax error, a message box showing

   “SUCCESS: PRESS ANY KEY” will be displayed.

5. To Execute the program: ALT + R (or) CTRL + F9
1.FIBONACCI SERIES

PROBLEM:

Write a C Program to generate the Fibonacci Series of 15 terms

0,1,2,3,5,8…………………..

AIM:

To generate the Fibonacci series of 15 terms.

PROGRAM CODING:

#include<stdio.h>
#include<conio.h>
void main( )
{
    clrscr( );
    int  a,b,c,i,n;
a=-1;
b=1;
printf("n Enter the N term to generate Fibonacci Series : ");
scanf("%d\n",&n)
for( i=0;i<=n;i++)
{
    c=a+b;
    printf("n%d",c);
a=b;
b=c;
}
getch( );
}
2. NUMBER OF VOWELS IN A STRING

PROBLEM:

Write a C Program to count the number of vowels in a given string.

AIM:

To write a C program to count the number of vowels in a given string.

PROGRAM CODING:

```c
#include<stdio.h>
#include<conio.h>
#include<string.h>

void main( )
{
    clrscr( );
    int i,j,k;
    char s[15];
    printf("n Enter the String in lower case");
    scanf("%s",&s);
    i=strlen(s);
    k=0;
    for(j=0;j<=i;j++)
```
if((s[j] == ’a’ || s[j] == ’e’ || s[j] == ’i’ || s[j] == ’o’ || s[j] == ’u’))
k=k+1;
}
printf("\n Number of vowels in the Given String %s is %d", s, k);
getch();
}

OUTPUT

Enter the String in lower case madam
Number of vowels in the Given String madam is 2

3.ADAM NUMBER

PROBLEM:
Write a C Program to display all Adam numbers between 10 and 100…….

AIM:
To write a C program to display all Adam numbers between 10 and 100.

PROGRAM CODING:

#include<stdio.h>
#include<conio.h>
#include<math.h>
void main()
{
    clrscr();
    int r,p,m,b,n,rev,a,c,i,z;
    r=0;
    rev=0;
printf("Enter any number between 10 to 100");
scanf("%d",&z);
n=z;
c=n*n;
while(n!=0)
{
m=n%10;
r=r*10+m;
n=n/10;
}
printf(" The Square of %d is \t %d",z,c);
printf(" The reverse of %d is \t %d",z,r);
p=r*r;
printf(" The Square of %d is \t %d",r,p);
while(c!=0)
{
a=c%10;
rev=rev*10+a;
c=c/10;
}
if(rev==p)
printf(" Thus %d is an Adam Number",z);
printf(" Thus %d is not an Adam Number",z);
getch();

OUTPUT

Enter any number between 10 to 100

The Square of 30 is    900
The reverse of 30 is    9
The Square of 3 is    9
Thus 30 is an Adam Number...
4. CONVERSION OF BINARY TO DECIMAL

PROBLEM:
Write a C Program to convert binary number to its equivalent decimal number.

AIM:
To write a C program to convert binary to its equivalent decimal number.

PROGRAM CODING:

```c
#include<stdio.h>
#include<conio.h>
void main( )
{
    clrscr( );
    int num,binary_val,decimal_val=0,base=1,rem;
    printf("Enter a binary number.........");
    scanf("%d", &num);
    binary_val=num;
    while(num>0)
    {
        rem=num%10;
        decimal_val=decimal_val+rem*base;
        num=num/10;
        base=base*2;
    }
    printf("The Binary number is =%d", binary_val);
    printf("Its decimal equivalent is =%d", decimal_val);
    getch( );
}
```

OUTPUT:

Enter the binary number.....
10111

The Binary number is =10111
Its decimal equivalent is =23
5. PERFECT NUMBER

PROBLEM:

Write a C Program to find the Perfect numbers from 1 to n terms

AIM:

To write a C program to find the Perfect numbers from 1 to n terms

PROGRAM CODING:

```c
#include<stdio.h>
#include<conio.h>

void main( )
{
    clrscr ( );
    int  i,j,n,s=0;
    printf("n Enter any number ");
    scanf("%d",&n);
    printf("n Perfect Numbers are");
    for(i=1;i<=n;i++)
    {
        s=0;
        for(j=1;j<i; j++)
        {
            if(i%j==0)
                s=s+j;
        }
        if(s==i)
            printf("n %d",i);
    }
    getch( );
}
```
6. PALINDROME

PROBLEM:
Write a C Program to find whether the given string is palindrome or not.

AIM:
To write a C program to find whether the given string is palindrome or not.

PROGRAM CODING:
```c
#include<stdio.h>
#include<conio.h>
#include<string.h>

void main( )
{
    clrscr( );
    char a[100], b[100];
    printf("n Enter the string to check if it is a palindrome or not");
    gets(a);
    strcpy(b,a);
    strrev(b);
    if(strcmp(a,b)==0)
        printf("n Entered string is a palindrome");
    else
```
```
printf("\n Entered string is not a palindrome");
getch();
}

OUTPUT

Enter the string to check if it a palindrome or notLIRIL
Entered string is a palindrome

====================================================================

7. DESCENDING ORDER

PROBLEM:

Write a C Program to arrange the array of “N” numbers in descending order.

AIM:

To write a C program to arrange the array of “N” numbers in descending order.

PROGRAM CODING:

#include<stdio.h>
#include<conio.h>

void main()
{
    clrscr();
    int a[10], i,j,temp=0,n;
    printf("\n Enter the terms…….");
    scanf("%d",&a[i]);
}
    for(i=0;j<n;i++)
    {
        for(j=i+1;j<n;j++)
        {
            temp=a[i];
            a[i]=a[j];
            a[j]=temp;
        }
    }
    printf("\n \n Array in descending order is:");
    for(i=0;i<10;i++)
    {
        printf("%d",a[i]);
    }
}
```c
{ 
    if(a[i] < a[j])
    {
        temp = a[j];
        a[j] = a[i];
        a[i] = temp;
    }
}

for(i=0; i<n; i++)
{
    printf("\n %d", a[i]);
}
getch();
}
```

**OUTPUT:**

```
Enter the terms...5
Enter the numbers...1
Enter the numbers...2
Enter the numbers...3
Enter the numbers...4
Enter the numbers...5
```

```
5
4
5
2
1
```
8. SUM OF DIAGONAL ELEMENTS OF A MATRIX

PROBLEM:
Write a C Program to find the sum of diagonal elements of a matrix.

AIM:
To write a C program to find the sum of diagonal elements of a matrix.

PROGRAM CODING:
#include<stdio.h>
#include<conio.h>
void main ( )
{
    clrscr( );
    int a[10][10],i,j,sum=0,m,n;
    printf("Enter the row and column of matrix");
    scanf("%d%d", &m, &n);
    printf("Enter the elements of matrix");
    for(i=0;i<m;i++)
    {
        for(j=0;j<n;j++)
            scanf("%d", &a[i][j]);
        printf("nThe matrix is \n");
    }
    for(i=0;i<m;i++)
    {
        printf("\n");
        for(j=0;j<m;j++)
            printf("%d\t", a[i][j]);
        printf("\n");
    }
}
for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
{
if(i==j)
    sum=sum+a[i][j];
}
}
printf("\n\nSum of the diagonal elements of a matrix is %d",sum);
getch();

OUTPUT:
Enter the row and column of matrix 3 3
Enter the elements of matrix 1
2
3
4
5
6
7
8
9
The matrix is
1  2  3
4  5  6
7  8  9
Sum of the diagonal elements of a matrix is 15
9. TRANSPOSE OF A MATRIX

PROBLEM:

Write a C Program to get Transpose of a matrix.

AIM:

To write a C program to get Transpose of a matrix.

PROGRAM CODING:

```c
#include<stdio.h>
#include<conio.h>

void main()
{
    clrscr( );
    int a[3][3],b[3][3],i,j;
    printf("Enter the values of Matrix A");
    for(i=0;i<3;i++)
    {
        for(j=0;j<3;j++)
        scanf("%d",a[i][ j ]);}
    for(i=0;i<3;i++)
    {
        for(j=0;j<3;j++)
        b[i][ j ] = a[ j ][i];
    }
    printf("A Matrix");
    printf("n");
    for(i=0;i<3;i++)
    {
        for(j=0;j<3;j++)
        printf("%d",b[i][ j ]);}
    }
```
printf("%d",a[i][ j ]);
printf("\n");
}
printf("\n\n Transposed Matrix");
printf("\n");
for(i=0;i<3;i++)
{
 for(j=0;j<3;j++)
 printf("%d",b[i][ j ]);
 printf("\n");
}
getch( );
}

OUTPUT:

```c
Enter the values of matrix A
1234
5678
A Matrix
1 4 7
2 5 8
3 6 9

Transpose Matrix
1 2 3
4 5 6
7 8 9
```
10. STORING AND PRINTING NAME IN AN ARRAY

**PROBLEM:**

Write a C Program to store 10 names in an array and print them each in the line.

**AIM:**

To write a C program to store 10 names in an array and print them each in the line.

**PROGRAM CODING:**

```c
#include<stdio.h>
#include<conio.h>

void main ( )
{
    clrscr( );
    printf("n enter 10 names \n");
    for(i=0;i<10;i++)
        scanf("%s",&a[i]);
    for(i=0;i<10;i++)
        printf("n%s",a[i]);
    getch( );
}
```
enter 10 names
ANAND
BALU
ARUN
MAGESH
HARI
SENTHIL
SELVA
MURUGAN
PRAVEEN
MOHAN

ANAND
BALU
ARUN
MAGESH
HARI
SENTHIL
SELVA
MURUGAN
PRAVEEN
MOHAN